summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-06-14 14:17:11 +0300
committerGöktürk Yüksek <gokturk@gentoo.org>2016-06-21 23:27:27 -0400
commitf875a676f99c4efc9cd8ae01c58f01384a504b48 (patch)
tree7c2b1ecb8491a198b594cc2c46d4fe6a06037f31 /app-editors/kakoune/kakoune-9999.ebuild
parentapp-editors/kakoune: fix the versioning scheme (diff)
downloadgentoo-f875a676f99c4efc9cd8ae01c58f01384a504b48.tar.gz
gentoo-f875a676f99c4efc9cd8ae01c58f01384a504b48.tar.bz2
gentoo-f875a676f99c4efc9cd8ae01c58f01384a504b48.zip
app-editors/kakoune: fix a linking bug
Fix a ncurses[tinfo] linking bug (see upstream https://github.com/mawww/kakoune/issues/695): moved configuration of ncurses linker libs to ebuild, until upstream supports pkg-config bind to current ncurses slot
Diffstat (limited to 'app-editors/kakoune/kakoune-9999.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-9999.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/app-editors/kakoune/kakoune-9999.ebuild b/app-editors/kakoune/kakoune-9999.ebuild
index f448c1b5403d..96ba4987975a 100644
--- a/app-editors/kakoune/kakoune-9999.ebuild
+++ b/app-editors/kakoune/kakoune-9999.ebuild
@@ -16,7 +16,7 @@ KEYWORDS=""
IUSE="debug"
RDEPEND="
- sys-libs/ncurses:*[unicode]
+ sys-libs/ncurses:=[unicode]
dev-libs/boost
"
DEPEND="
@@ -29,18 +29,12 @@ PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
src_configure() {
append-cppflags $(pkg-config --cflags ncursesw)
+ append-libs $(pkg-config --libs ncursesw)
export CXX=$(tc-getCXX)
export debug=$(usex debug)
-}
-
-src_compile() {
- emake -C src
-}
-
-src_test() {
- emake -C src test
+ S="${WORKDIR}/${P}/src"
}
src_install() {
- emake -C src DESTDIR="${D}" PREFIX="/usr" install
+ emake DESTDIR="${D}" PREFIX="/usr" install
}