summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-05-15 21:01:18 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-05-16 08:40:16 +0000
commit8537787ac225648b95d8db8cdd5707ab238c5d16 (patch)
tree61dd2827194a50f325708077a157aabab9afed9f /app-editors/kakoune
parentx11-wm/jwm: fix hompage (diff)
downloadgentoo-8537787ac225648b95d8db8cdd5707ab238c5d16.tar.gz
gentoo-8537787ac225648b95d8db8cdd5707ab238c5d16.tar.bz2
gentoo-8537787ac225648b95d8db8cdd5707ab238c5d16.zip
app-editors/kakoune: version bump to 2016.05.15
Closes: https://github.com/gentoo/gentoo/pull/1472 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-editors/kakoune')
-rw-r--r--app-editors/kakoune/Manifest1
-rw-r--r--app-editors/kakoune/kakoune-2016.05.15.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/kakoune/Manifest b/app-editors/kakoune/Manifest
index f74622d2f437..5ecf5c964ef1 100644
--- a/app-editors/kakoune/Manifest
+++ b/app-editors/kakoune/Manifest
@@ -1 +1,2 @@
DIST kakoune-2016.05.05.tar.gz 367575 SHA256 e79655b89d6138547d7158e715b520c98316b0358ced6c356496b361c9ea0049 SHA512 9b6cc2c9c6c356a27f5a42a226ba2fb2ce32e21e795423a6354127f9dce7edd423e61a9356a0582d609efc4c28dd012788556cc32ba3f8f791a901f07a36bbc8 WHIRLPOOL e71748f69bca77dd9cd6c02c92f032123d322861bf86ab63bd5561b1f7957ec68c6b7ce0e1f8dd493166cf22aceae7cd49e6ffd42816c7c265712e554b224fe0
+DIST kakoune-2016.05.15.tar.gz 369625 SHA256 e826e9225ca2ac13d4b0b5587481aaf59dc2421d93f376b21056199c4f8df9bc SHA512 09651fe485c55c35b878d14044cef565fd5c38c91e658181e051d0034886b30f8dc53a33c79f2d28bb64f51719c4d688a91978020308b01e8a6663eb2b556954 WHIRLPOOL dc403e37399850508135e9a584cc4e49dd7d52b7c573f28cff3346a5c8cca4821361b71da62312bf4d13fe09b7e43c94888159d96fc13cb788ba902353121417
diff --git a/app-editors/kakoune/kakoune-2016.05.15.ebuild b/app-editors/kakoune/kakoune-2016.05.15.ebuild
new file mode 100644
index 000000000000..524324d6dd58
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2016.05.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs vcs-snapshot
+
+REF="1788126f385c0d656b6addb0731f6205cc4856e5"
+
+DESCRIPTION="Selection-oriented code editor inspired by vim"
+HOMEPAGE="https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/${PN}/tarball/${REF} -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ sys-libs/ncurses:*[unicode]
+ dev-libs/boost
+"
+DEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+
+src_configure() {
+ append-cppflags $(pkg-config --cflags ncursesw)
+ export CXX=$(tc-getCXX)
+ export debug=$(usex debug)
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_test() {
+ emake -C src test
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" PREFIX="/usr" install
+}