summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-05-12 00:46:18 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-05-12 00:47:29 +0300
commitf41585c6b64573b0f9927fc403f366cc21c7ead7 (patch)
tree031ee5f94fbd41ed8759455b9f742f94428d364a /app-editors/moe/moe-1.9.ebuild
parentprofiles/package.mask: drop media-fonts/bitstream-cyberbit mask (diff)
downloadgentoo-f41585c6b64573b0f9927fc403f366cc21c7ead7.tar.gz
gentoo-f41585c6b64573b0f9927fc403f366cc21c7ead7.tar.bz2
gentoo-f41585c6b64573b0f9927fc403f366cc21c7ead7.zip
app-editors/moe: Version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-editors/moe/moe-1.9.ebuild')
-rw-r--r--app-editors/moe/moe-1.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/moe/moe-1.9.ebuild b/app-editors/moe/moe-1.9.ebuild
new file mode 100644
index 000000000000..c511c32637fa
--- /dev/null
+++ b/app-editors/moe/moe-1.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs unpacker
+
+DESCRIPTION="A powerful and user-friendly console text editor"
+HOMEPAGE="https://www.gnu.org/software/moe/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ $(unpacker_src_uri_depends)
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ tc-export CXX PKG_CONFIG
+ sed -i \
+ -e "/^CXXFLAGS=/d" \
+ -e "/^LDFLAGS=/d" \
+ -e "/^CXX=/d" \
+ configure || die "sed on configure failed"
+
+ eapply_user
+
+ eapply "${FILESDIR}/${PN}-1.6-tinfo.patch"
+}