summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErvin Peters <coder@ervnet.de>2021-12-11 10:47:47 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-12-20 13:05:01 +0200
commit994ea441e7f3adb4a8107cace724bbbf25c29bbb (patch)
tree741c869dd32e7a17ec4cf1074925de52ebe970f3 /app-editors/scite
parentapp-misc/pet: version bump to 0.4.0 (diff)
downloadgentoo-994ea441e7f3adb4a8107cace724bbbf25c29bbb.tar.gz
gentoo-994ea441e7f3adb4a8107cace724bbbf25c29bbb.tar.bz2
gentoo-994ea441e7f3adb4a8107cace724bbbf25c29bbb.zip
app-editors/scite: remove 4.4.4-r10 due to compile bugs
There is an error in compiling with current glib-2 and a stable 5.x.x is available which fixes this. Signed-off-by: Ervin Peters <coder@ervnet.de> Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/scite')
-rw-r--r--app-editors/scite/Manifest1
-rw-r--r--app-editors/scite/scite-4.4.4-r10.ebuild123
2 files changed, 0 insertions, 124 deletions
diff --git a/app-editors/scite/Manifest b/app-editors/scite/Manifest
index 8c3caadf3bd2..e4c9669085d3 100644
--- a/app-editors/scite/Manifest
+++ b/app-editors/scite/Manifest
@@ -1,3 +1,2 @@
-DIST scite-4.4.4.tgz 2775628 BLAKE2B a7607b53bf529c56f6525d44b052a08c914d8aa1d90d475dcf46927ac5ce83c06d68b70e8d8e8969c77c367240ba1e7ac10d599c77002575e84b9baf6445d03b SHA512 1e8529286206d542e0c07353b73ab38aa9ee2e2256ed8e15328965e00a33eb026f79bd7d330253e8743cf5503fadb32c64162973ad21da16993f11e124842ec0
DIST scite-5.1.1.tgz 3374717 BLAKE2B b7a45a86008eb592adacc8fde90cb637cc7cac821f339bb65920aaf912ee10d52badde3ed2e71118a7ce4690a0536b298c5fe5f673b886902ad4634b3a1ffaa6 SHA512 4d6c9b3ca4caed4fcb70a6b1c86a2ace13b023241f16d6faa01b3f692bcbfa14e0ce186bb08776ee0cf62768b2b77c4ffcae610ddbb6b04dcb7584fd8b3f27bb
DIST scite-5.1.3.tgz 3427245 BLAKE2B ca765b61cb1fa96934c1e28d76a97cd7086a6c692ae33bb57591dfbc8637ffc94c4a3f20f9c6b55d11da8a76664f1d521f7e393bf6f31db55cbe02e0bf5052ba SHA512 ef86a18f739062598d3c7bf19bcd2f38ca012e890b9b4685c1f1b809e928762ab60d24c33a1f45ca33133ce5007e3a22a76e80222b121c9a4089d3c57aa0bc4c
diff --git a/app-editors/scite/scite-4.4.4-r10.ebuild b/app-editors/scite/scite-4.4.4-r10.ebuild
deleted file mode 100644
index 1f2fd9e64c95..000000000000
--- a/app-editors/scite/scite-4.4.4-r10.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-1 )
-
-inherit lua-single toolchain-funcs xdg-utils
-
-DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring"
-HOMEPAGE="https://www.scintilla.org/SciTE.html"
-SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz"
-
-LICENSE="HPND lua? ( MIT )"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="lua"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/glib:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:3
- x11-libs/pango
- lua? ( ${LUA_DEPS} )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig"
-
-DOCS=("../README")
-
-S="${WORKDIR}/${PN}/gtk"
-
-pkg_pretend() {
- if tc-is-clang ; then
- # need c++17 features
- [[ "${MERGE_TYPE}" != "binary" &&
- $(clang-major-version) -lt 5 ]] &&
- die "Sorry, SCiTE uses C++17 Features and needs >sys-devel/clang-5
- ($(clang-major-version))."
-
- elif tc-is-gcc; then
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" &&
- $(gcc-major-version) -lt 7 ]] &&
- die "Sorry, Scite uses C++17 Features, need >sys-devel/gcc-7."
- else
- die "Either gcc or clang should be configured for building scite"
- fi
-}
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- tc-export AR CC CXX RANLIB
-
- # remove hardcoded CC, Optimizations and clang unknown flags
- sed -i "${WORKDIR}/scintilla/gtk/makefile" \
- -e "s#^CC = gcc#CC = ${CC}#" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-Os##" \
- -e "s#-Wno-misleading-indentation##" \
- || die "error patching /scintilla/gtk/makefile"
-
- sed -i "${S}/makefile" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
- -e "s#-Os##" \
- || die "error patching gtk/makefile"
-
- # repair and enhance the .desktop file
- sed -i "${S}/SciTE.desktop" \
- -e "s#text/plain#text/\*;application/xhtml+xml#" \
- -e "s#^Categories=\(.*\)#Categories=Development;#" \
- || die "error patching /scite/gtk/SciTe.desktop"
-
- # add the ebuild suffix as shell type for working with ebuilds
- sed -i "${WORKDIR}/scite/src/perl.properties" \
- -e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
- || die "error patching /scite/src/perl.properties"
-
- # it seems that pwd here is ${S}, but user patches are relative to ${workdir}
- # Bug #576162
-
- cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
- eapply_user
-}
-
-src_compile() {
- # prepare make options
- local emake_pars=("GTK3=1")
-
- tc-is-clang && emake_pars+=("CLANG=1")
- use !lua && emake_pars+=("NO_LUA=1")
-
- emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}"
- emake "${emake_pars[@]}"
-}
-
-# want to use the base src_install() as base_src_install()
-
-src_install() {
- default
- dosym SciTE /usr/bin/scite
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}