summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-12-16 05:06:01 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-12-16 05:06:49 +1100
commitbe2a27a2420611603545bbec64fa2b26ab1034e4 (patch)
tree5127f66d92a65c8fa578f9c51478a3d10b96dd6d /app-editors/tea
parentapp-editors/qxmledit: remove old (diff)
downloadgentoo-be2a27a2420611603545bbec64fa2b26ab1034e4.tar.gz
gentoo-be2a27a2420611603545bbec64fa2b26ab1034e4.tar.bz2
gentoo-be2a27a2420611603545bbec64fa2b26ab1034e4.zip
app-editors/tea: version bump
Gentoo-bug: 561080 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/Manifest1
-rw-r--r--app-editors/tea/tea-41.1.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-editors/tea/Manifest b/app-editors/tea/Manifest
index 631584cfc4ab..8f80d509e3ee 100644
--- a/app-editors/tea/Manifest
+++ b/app-editors/tea/Manifest
@@ -1,2 +1,3 @@
DIST tea-36.0.2.tar.bz2 315046 SHA256 6541b645451de3f6eefce58b55a302224b925bdbdb9efcfa1491bcf867baad6f SHA512 e04df49e8381c69f0e2fb6900d6f095b0eb15bdc2d8fb935230129b2fef7560fd91936d66a2440d1922a6fc6c2e7d07e40fe1106b5cf22dd495bba667cf5def8 WHIRLPOOL 1da79f26126c98876ff6bfef04c799f476a204294466cbd47834748a12e8c59d10f7c2e36d4ebc089fcef21caca1beeab1293acee13da9af341466c117873e1f
DIST tea-41.0.0.tar.bz2 381891 SHA256 b20bfe3235a4f405bcd984adfabde2302a15cf8512e19f8b97bc43ce9911632b SHA512 aff52922be7650a23fcafe5a8106d5955bc7c68a901ad6a3982b71196ac8856939d3bc61236babbed21a749c2fc205510ef081ac35d7d33fcf2d2700ebb5cbaf WHIRLPOOL ed913f3fb424e47fbbecab445ccd9c34c9ad66befdda950fee05958459b87efad67cfea37548c5ab8456b849c860f0cd3ef59e386aaa99c01b5041dae02c1afc
+DIST tea-41.1.0.tar.bz2 381370 SHA256 65ea128739802b7626a5a59de12b0e885dcef7a83f7bcd06b6d3aea830ed8717 SHA512 a46e0cdfce5c7d453c7783c59ad98b2b029847ddcc8ce0655c6e1ae45825426ac1b271ca7ad90f0219d8f796f507f6bdba0f2c764c563c8c23503b94be817eb7 WHIRLPOOL a3d00f5e42a145be2a7f3bf846832bf2a7e95e957abf4c928118be7607adb57fddfb906fbedaf7fa51665b25629beae0fe5b4db40886f42dfcf5c166e43717b5
diff --git a/app-editors/tea/tea-41.1.0.ebuild b/app-editors/tea/tea-41.1.0.ebuild
new file mode 100644
index 000000000000..c1f2497a05e6
--- /dev/null
+++ b/app-editors/tea/tea-41.1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PLOCALES="de fr ru"
+
+inherit eutils l10n qmake-utils
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="http://tea.ourproject.org/ http://semiletov.org/tea/"
+SRC_URI="http://tea.ourproject.org/dloads/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="aspell hunspell"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ sys-libs/zlib
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+"
+DEPEND="${RDEPEND}
+ hunspell? ( virtual/pkgconfig )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS TODO )
+
+src_configure() {
+ eqmake4 src.pro \
+ $(use aspell || echo CONFIG+=noaspell) \
+ $(use hunspell || echo CONFIG+=nohunspell)
+}
+
+src_install() {
+ dobin bin/tea
+
+ newicon icons/tea-icon-v3-01.png ${PN}.png
+ make_desktop_entry ${PN} 'Tea Editor'
+
+ # translations
+ insinto /usr/share/qt4/translations
+ local lang
+ for lang in $(l10n_get_locales); do
+ doins translations/${PN}_${lang}.qm
+ done
+
+ # docs
+ dohtml manuals/en.html
+ if use linguas_ru; then
+ dodoc NEWS-RU
+ dohtml manuals/ru.html
+ fi
+}