summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-07-26 00:04:46 -0400
committerTim Harder <radhermit@gentoo.org>2016-07-26 00:20:19 -0400
commita7c5ab06bbefa299cdf7b8f2814a8bdd685009f1 (patch)
tree729a6eb6b9c6453b723327f82340815db0403ebf /app-editors/vim-core/vim-core-9999.ebuild
parentmedia-sound/meterbridge: linkage fix, EAPI 6 (diff)
downloadgentoo-a7c5ab06bbefa299cdf7b8f2814a8bdd685009f1.tar.gz
gentoo-a7c5ab06bbefa299cdf7b8f2814a8bdd685009f1.tar.bz2
gentoo-a7c5ab06bbefa299cdf7b8f2814a8bdd685009f1.zip
app-editors/vim-core: version bump to 7.4.2102
Diffstat (limited to 'app-editors/vim-core/vim-core-9999.ebuild')
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index 5e2f6a16ebcd..a3e437e529ce 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
VIM_VERSION="7.4"
inherit eutils vim-doc flag-o-matic versionator bash-completion-r1 prefix
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999* ]] ; then
EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
else
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
- https://dev.gentoo.org/~radhermit/vim/vim-7.4.827-gentoo-patches.tar.bz2"
+ https://dev.gentoo.org/~radhermit/vim/vim-7.4.2102-gentoo-patches.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -40,11 +40,8 @@ pkg_setup() {
src_prepare() {
if [[ ${PV} != 9999* ]] ; then
- if [[ -d "${WORKDIR}"/patches/ ]]; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patches/
- fi
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ eapply "${WORKDIR}"/patches
fi
# Fixup a script to use awk instead of nawk
@@ -93,7 +90,7 @@ src_prepare() {
"${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
fi
- epatch_user
+ default
}
src_configure() {