summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-28 16:18:24 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-28 16:24:09 -0600
commit60d656fac07ee43efbe05408cd5082a64612e883 (patch)
tree2d3c40d13cfecfabc4ef04b10b67abc646fc020f /app-editors/vim
parentapp-editors/gvim: use PDEPEND to allow upgrades past icon file collision (diff)
downloadgentoo-60d656fac07ee43efbe05408cd5082a64612e883.tar.gz
gentoo-60d656fac07ee43efbe05408cd5082a64612e883.tar.bz2
gentoo-60d656fac07ee43efbe05408cd5082a64612e883.zip
app-editors/vim: drop unnecessary icon cache update
Icon is installed by vim-core which runs the cache update as well. Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/vim-8.1.0648.ebuild8
-rw-r--r--app-editors/vim/vim-9999.ebuild8
2 files changed, 6 insertions, 10 deletions
diff --git a/app-editors/vim/vim-8.1.0648.ebuild b/app-editors/vim/vim-8.1.0648.ebuild
index abe19b7c71ab..53057996e0d8 100644
--- a/app-editors/vim/vim-8.1.0648.ebuild
+++ b/app-editors/vim/vim-8.1.0648.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
PYTHON_REQ_USE="threads(+)"
USE_RUBY="ruby23 ruby24 ruby25"
-inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop xdg-utils gnome2-utils
+inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop xdg-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -303,9 +303,8 @@ pkg_postinst() {
# Call eselect vi update
eselect_vi_update
- # update desktop file mime/icon caches
+ # update desktop file mime cache
xdg_desktop_database_update
- gnome2_icon_cache_update
}
pkg_postrm() {
@@ -315,7 +314,6 @@ pkg_postrm() {
# Call eselect vi update
eselect_vi_update
- # update desktop file mime/icon caches
+ # update desktop file mime cache
xdg_desktop_database_update
- gnome2_icon_cache_update
}
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index abe19b7c71ab..53057996e0d8 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
PYTHON_REQ_USE="threads(+)"
USE_RUBY="ruby23 ruby24 ruby25"
-inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop xdg-utils gnome2-utils
+inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop xdg-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -303,9 +303,8 @@ pkg_postinst() {
# Call eselect vi update
eselect_vi_update
- # update desktop file mime/icon caches
+ # update desktop file mime cache
xdg_desktop_database_update
- gnome2_icon_cache_update
}
pkg_postrm() {
@@ -315,7 +314,6 @@ pkg_postrm() {
# Call eselect vi update
eselect_vi_update
- # update desktop file mime/icon caches
+ # update desktop file mime cache
xdg_desktop_database_update
- gnome2_icon_cache_update
}