summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-12 19:34:14 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-12 19:37:57 +0200
commit0d3bc4b17ec86243faeff7b08cf09e941fbf1ec5 (patch)
tree5e9599686886477ac0dfbfe4b0f0633a465a372a /app-editors
parentapp-editors/vscode: add 1.74.3 (diff)
downloadgentoo-0d3bc4b17ec86243faeff7b08cf09e941fbf1ec5.tar.gz
gentoo-0d3bc4b17ec86243faeff7b08cf09e941fbf1ec5.tar.bz2
gentoo-0d3bc4b17ec86243faeff7b08cf09e941fbf1ec5.zip
app-editors/vscodium: add 1.74.3.23010
Bug: https://bugs.gentoo.org/890565 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.74.3.23010.ebuild118
2 files changed, 121 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 6071675b4bd1..503a86351324 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -7,3 +7,6 @@ DIST vscodium-1.74.1.22349-arm64.tar.gz 114469077 BLAKE2B 3751a2a25d32917fd71e78
DIST vscodium-1.74.2.22355-amd64.tar.gz 121392747 BLAKE2B c94de3bb8f0bce582aa0dc983f6215be2a0c21676e57a0a9eed63f667708f2ed3694f84041c9e6a4aeaf6aa6c86d3ca8d9801358af93a127ec7b12ccf2b07870 SHA512 b1e6bac2a3d08a903a2906f0b514e64e44a50d6be1318214431a3d851010c724dcb7e1e28a1e01ab7e09fdf486cbf667040e4b80084a0be62125c814160326e7
DIST vscodium-1.74.2.22355-arm.tar.gz 103437753 BLAKE2B 215a7bc9e5f5137742885b3bb06e3e45fbc6b9c267b1653db04ee746e69794ba2be789c59322e80a486a63c38744cd471c0a9b3b0ce1a52222e4d86e2f38a16b SHA512 c556b7e0413c0e4af098c8f5443cbe3c58a4a7ede8b5fe5dadb8f1faa97413c006a430702ad93002950584ca94d10cdd22465e7f37de6b1bb8af1f430644a505
DIST vscodium-1.74.2.22355-arm64.tar.gz 114464524 BLAKE2B 3c2e166ef1bee641c3082267fe62ae80858c044f5aae62c656c95288282174e81a3961465b45222fe3dd97abfdb2a4e81c2969e0e0d95981c783dbebf23266b0 SHA512 6b956d286a6a335bd87b321b353f5e857844c6ab8b45bfeb141cd49ab0d42d62f3d857270001ebd77eef81dbdd53671c8de84861e61b87186533580f7e00e5b1
+DIST vscodium-1.74.3.23010-amd64.tar.gz 121396318 BLAKE2B 457aa7135d85340cc46b8bf06cc18bf9a575510c445c25c2102aa9f95099e7472f953c1770c7ff567bb53a2532db2c21849b06e922ef11a5d8699f8ed3cd283b SHA512 4d6f9494c2112c6de60dde67eab6127c8bbb7fae4574e6fa85e4438e02ccf61f0954e79157e0466dd7aa2cead828d394b6b8f669be4ff52050b2cafb3e3e7f6b
+DIST vscodium-1.74.3.23010-arm.tar.gz 103438321 BLAKE2B e6294cdaaed7862b7a64ff9cfdb675ccba1bca25c23ba66c93aaadb2e231447de7baba4815ee910a1b84965ffdee06c1b6a45a48294872a0c872ed10e049a05a SHA512 52f481e5a7e9f53c176702b134729f6fff0a8fe4eb993d07350476250bb324ef88fc22e3263c018affc5f791bf65583946da8119dc657fec372741a81798fa81
+DIST vscodium-1.74.3.23010-arm64.tar.gz 114464176 BLAKE2B a6682c4c26fa2bb628aced21cfabe0ee03cc3bb285b857973753cb9c5798763d6c43d8968f089a2be064a84ce71fc09ea938f5305c30c0a8920968c75812c845 SHA512 a2d563fc69aad4e3c05afe88c6326a2a9e2e67c7022e6068f416348445d421a0c1a676ecb405acca1f9b2892e1cdbbc7f38e6292570deaa5bc4574506deb272d
diff --git a/app-editors/vscodium/vscodium-1.74.3.23010.ebuild b/app-editors/vscodium/vscodium-1.74.3.23010.ebuild
new file mode 100644
index 000000000000..e504e2b38051
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.74.3.23010.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}