summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-22 00:39:04 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-22 00:39:34 +0000
commit0ea4de07ab346251fccf610c8c7618360cd43a24 (patch)
tree6e6bd18788530564075fbdaa46ed1a426e2fbc2d /app-editors
parentdev-java/openjfx: bump to 11.0.6_p2 (diff)
downloadgentoo-0ea4de07ab346251fccf610c8c7618360cd43a24.tar.gz
gentoo-0ea4de07ab346251fccf610c8c7618360cd43a24.tar.bz2
gentoo-0ea4de07ab346251fccf610c8c7618360cd43a24.zip
app-editors/hteditor: tweak for gcc-10
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch36
-rw-r--r--app-editors/hteditor/hteditor-2.1.0-r1.ebuild3
2 files changed, 38 insertions, 1 deletions
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch b/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch
new file mode 100644
index 000000000000..3516efd2871b
--- /dev/null
+++ b/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch
@@ -0,0 +1,36 @@
+Backport a subset of upstream c++11 fixes.
+--- a/htmacho.cc
++++ b/htmacho.cc
+@@ -146,7 +146,7 @@ void ht_macho::init(Bounds *b, File *f, format_viewer_if **ifs, ht_format_group
+ break;
+ case MACHO_CPU_TYPE_I386:
+ switch (c->flavor) {
+- case -1:
++ default:
+ createHostStruct(&c->state, MACHO_I386_THREAD_STATE_struct, image_endianess);
+ break;
+ }
+--- a/htmachohd.cc
++++ b/htmachohd.cc
+@@ -313,7 +313,7 @@ static ht_view *htmachoheader_init(Bounds *b, File *file, ht_format_group *group
+ switch (macho_shared->header.cputype) {
+ case MACHO_CPU_TYPE_I386:
+ switch (c->flavor) {
+- case -1:
++ default:
+ m->add_staticmask_ptable(macho_i386_thread_state, ofs+4*4/*4 32bit words in thread_header*/, isbigendian);
+ break;
+ }
+--- a/io/types.h
++++ b/io/types.h
+@@ -87,8 +87,8 @@ union htmsg_param {
+ };
+
+ struct htmsg {
+- int msg;
+- int type;
++ unsigned int msg;
++ unsigned int type;
+ htmsg_param data1;
+ htmsg_param data2;
+ };
diff --git a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild b/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
index 8798cd47595b..5b468939e1f1 100644
--- a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
+++ b/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,6 +32,7 @@ PATCHES=(
"${FILESDIR}"/${P}-tinfo.patch
"${FILESDIR}"/${P}-gcc-6-uchar.patch
"${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
)
src_prepare() {