summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-05-14 10:14:20 +0200
committerUlrich Müller <ulm@gentoo.org>2023-05-14 10:15:33 +0200
commit16774da623f4683a6858db278c7a94462251a5ce (patch)
tree2d6785381e30fed526b4f5b569f956db94346f87 /app-editors
parentgnome-base/gnome-keyring: add Valgrind annotation support (diff)
downloadgentoo-16774da623f4683a6858db278c7a94462251a5ce.tar.gz
gentoo-16774da623f4683a6858db278c7a94462251a5ce.tar.bz2
gentoo-16774da623f4683a6858db278c7a94462251a5ce.zip
app-editors/emacs: Move a comment
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-29.0.90.ebuild16
-rw-r--r--app-editors/emacs/emacs-29.0.9999-r1.ebuild16
-rw-r--r--app-editors/emacs/emacs-30.0.9999.ebuild16
3 files changed, 24 insertions, 24 deletions
diff --git a/app-editors/emacs/emacs-29.0.90.ebuild b/app-editors/emacs/emacs-29.0.90.ebuild
index 1d73792abc64..4b9556db2893 100644
--- a/app-editors/emacs/emacs-29.0.90.ebuild
+++ b/app-editors/emacs/emacs-29.0.90.ebuild
@@ -214,6 +214,14 @@ src_configure() {
myconf+=" --with-sound=$(usex sound oss)"
fi
+ if use jit; then
+ use zlib || ewarn \
+ "USE flag \"jit\" overrides \"-zlib\"; enabling zlib support."
+ myconf+=" --with-zlib"
+ else
+ myconf+=" $(use_with zlib)"
+ fi
+
# Emacs supports these window systems:
# X11, pure GTK (without X11), or Nextstep (Aqua/Cocoa).
# General GUI support is enabled by the "gui" USE flag, then
@@ -225,14 +233,6 @@ src_configure() {
# Athena (Lucid), or no toolkit. They are enabled (in order of
# preference) with the "gtk", "motif", "Xaw3d", and "athena" flags.
- if use jit; then
- use zlib || ewarn \
- "USE flag \"jit\" overrides \"-zlib\"; enabling zlib support."
- myconf+=" --with-zlib"
- else
- myconf+=" $(use_with zlib)"
- fi
-
if ! use gui; then
einfo "Configuring to build without window system support"
myconf+=" --without-x --without-pgtk --without-ns"
diff --git a/app-editors/emacs/emacs-29.0.9999-r1.ebuild b/app-editors/emacs/emacs-29.0.9999-r1.ebuild
index 1d73792abc64..4b9556db2893 100644
--- a/app-editors/emacs/emacs-29.0.9999-r1.ebuild
+++ b/app-editors/emacs/emacs-29.0.9999-r1.ebuild
@@ -214,6 +214,14 @@ src_configure() {
myconf+=" --with-sound=$(usex sound oss)"
fi
+ if use jit; then
+ use zlib || ewarn \
+ "USE flag \"jit\" overrides \"-zlib\"; enabling zlib support."
+ myconf+=" --with-zlib"
+ else
+ myconf+=" $(use_with zlib)"
+ fi
+
# Emacs supports these window systems:
# X11, pure GTK (without X11), or Nextstep (Aqua/Cocoa).
# General GUI support is enabled by the "gui" USE flag, then
@@ -225,14 +233,6 @@ src_configure() {
# Athena (Lucid), or no toolkit. They are enabled (in order of
# preference) with the "gtk", "motif", "Xaw3d", and "athena" flags.
- if use jit; then
- use zlib || ewarn \
- "USE flag \"jit\" overrides \"-zlib\"; enabling zlib support."
- myconf+=" --with-zlib"
- else
- myconf+=" $(use_with zlib)"
- fi
-
if ! use gui; then
einfo "Configuring to build without window system support"
myconf+=" --without-x --without-pgtk --without-ns"
diff --git a/app-editors/emacs/emacs-30.0.9999.ebuild b/app-editors/emacs/emacs-30.0.9999.ebuild
index eb6ca29d5da6..6b5a455c09ea 100644
--- a/app-editors/emacs/emacs-30.0.9999.ebuild
+++ b/app-editors/emacs/emacs-30.0.9999.ebuild
@@ -214,6 +214,14 @@ src_configure() {
myconf+=" --with-sound=$(usex sound oss)"
fi
+ if use jit; then
+ use zlib || ewarn \
+ "USE flag \"jit\" overrides \"-zlib\"; enabling zlib support."
+ myconf+=" --with-zlib"
+ else
+ myconf+=" $(use_with zlib)"
+ fi
+
# Emacs supports these window systems:
# X11, pure GTK (without X11), or Nextstep (Aqua/Cocoa).
# General GUI support is enabled by the "gui" USE flag, then
@@ -225,14 +233,6 @@ src_configure() {
# Athena (Lucid), or no toolkit. They are enabled (in order of
# preference) with the "gtk", "motif", "Xaw3d", and "athena" flags.
- if use jit; then
- use zlib || ewarn \
- "USE flag \"jit\" overrides \"-zlib\"; enabling zlib support."
- myconf+=" --with-zlib"
- else
- myconf+=" $(use_with zlib)"
- fi
-
if ! use gui; then
einfo "Configuring to build without window system support"
myconf+=" --without-x --without-pgtk --without-ns"