summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-07-01 15:07:59 -0700
committerDavid Seifert <soap@gentoo.org>2017-07-01 15:09:45 -0700
commit4f90be61f21ab87daafa51a38dbffef0d423480a (patch)
tree68a1c45e2e49b873eba251b4c159ff435482b785 /app-editors
parentprofiles: Mask kde-apps/gpgmepp for removal (diff)
downloadgentoo-4f90be61f21ab87daafa51a38dbffef0d423480a.tar.gz
gentoo-4f90be61f21ab87daafa51a38dbffef0d423480a.tar.bz2
gentoo-4f90be61f21ab87daafa51a38dbffef0d423480a.zip
app-editors/sublime-text: Initial addition
* Ebuilds taken from https://github.com/DamnWidget/sublime-text and simplified (no eselect module) and updated to EAPI 6. Bug: https://bugs.gentoo.org/show_bug.cgi?id=405461 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/sublime-text/Manifest4
-rw-r--r--app-editors/sublime-text/metadata.xml7
-rw-r--r--app-editors/sublime-text/sublime-text-2.0.2.ebuild52
-rw-r--r--app-editors/sublime-text/sublime-text-3_pre3126.ebuild53
4 files changed, 116 insertions, 0 deletions
diff --git a/app-editors/sublime-text/Manifest b/app-editors/sublime-text/Manifest
new file mode 100644
index 000000000000..522b47507505
--- /dev/null
+++ b/app-editors/sublime-text/Manifest
@@ -0,0 +1,4 @@
+DIST sublime-text-2.0.2_x32.tar.bz2 5584673 SHA256 07338e041cfb348938fa8069f0aad3b5b43c319b7ec564ffff1489796f2dcf08 SHA512 08d99183a102b376109a140f2c58cac2ecd49179e639a80da9860ae03a223229df217c9316b7571b10b59983ad49d8145b86c6e20175f3cd87021aca1d7527bc WHIRLPOOL 725c0ce10bc439f04157ea9050277f37a4807c847ab8dd38ca1db205c1228037b8678eeb5b19ba5a79c4711b2101d630b5bfc82e50ddb6ccba1b9d011808a1d5
+DIST sublime-text-2.0.2_x64.tar.bz2 5662968 SHA256 01baed30d66432e30002a309ff0393967be1daba5cce653e43bba6bd6c38ab84 SHA512 330dc9c4141d0e01f19605b397126b9ca0703377d565cbc552f4bc622ba54b38dbf2485aca71d6f24e3160e71ea40b2057ce66a3907ff6766916fb39438e9113 WHIRLPOOL 167a60f851ee14c1879b422987ef9c496c64d924b2fc94ce8dd19d95847d31c184bb24cbb50293044f37e60336b9349ec7f7a689f7f2d0f076db432dfdf5d713
+DIST sublime_text_3_build_3126_x32.tar.bz2 9258647 SHA256 92ffefa470f0777897ed0dfb7c1635426105271da9b5affbe8c1e82039718e29 SHA512 f8377adbad072577995918c7c8311ae63c7290581b00200e698ded18722893edf0baa7227480c8fc6143be30d695fae1e7312f7a9ac6728b8a397ea814a829fa WHIRLPOOL 7f45a898aa036cc56ea931bc6b0ae48499d60e5b640700724874bc22414d44f0b04e4df939a5a9c968b65fdd71c2be060daf57bf269fbfdc4ef463ba6e6b058d
+DIST sublime_text_3_build_3126_x64.tar.bz2 9313954 SHA256 18db132e9a305fa3129014b608628e06f9442f48d09cfe933b3b1a84dd18727a SHA512 a0a683b3cef45fba2a294cb044e5dc24ed3ea8d8a669321ee15844a48b88fbd345d50f499a9feb865735b15b44ff99d6b5f8aaee453245b9fd61e9e3d1c69f26 WHIRLPOOL f41520ed96db71de1fca374ba36645016f72801ea17a983c865eaeb7835cda75ee9dbd9cebca247b961dd6db29ca9f9d2c6babb076dba49b3660ef56c9c97d43
diff --git a/app-editors/sublime-text/metadata.xml b/app-editors/sublime-text/metadata.xml
new file mode 100644
index 000000000000..3c5abf825aef
--- /dev/null
+++ b/app-editors/sublime-text/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-editors/sublime-text/sublime-text-2.0.2.ebuild b/app-editors/sublime-text/sublime-text-2.0.2.ebuild
new file mode 100644
index 000000000000..68b9fdd7e906
--- /dev/null
+++ b/app-editors/sublime-text/sublime-text-2.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils
+
+# get the major version from PV
+MV=${PV:0:1}
+
+DESCRIPTION="Sophisticated text editor for code, markup and prose"
+HOMEPAGE="http://www.sublimetext.com"
+SRC_URI="
+ amd64? ( https://download.sublimetext.com/Sublime%20Text%20${PV}%20x64.tar.bz2 -> ${P}_x64.tar.bz2 )
+ x86? ( https://download.sublimetext.com/Sublime%20Text%20${PV}.tar.bz2 -> ${P}_x32.tar.bz2 )"
+
+LICENSE="Sublime"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ dbus? ( sys-apps/dbus )"
+
+QA_PREBUILT="*"
+S="${WORKDIR}/Sublime Text ${MV}"
+
+# Sublime bundles the kitchen sink, which includes python and other assorted
+# modules. Do not try to unbundle these because you are guaranteed to fail.
+
+src_install() {
+ insinto /opt/${PN}${MV}
+ doins -r "Pristine Packages" lib
+ doins sublime_plugin.py PackageSetup.py
+
+ exeinto /opt/${PN}${MV}
+ doexe sublime_text
+ dosym ../../opt/${PN}${MV}/sublime_text /usr/bin/sublime_text
+
+ local size
+ for size in 16 32 48 128 256; do
+ newicon -s ${size} Icon/${size}x${size}/sublime_text.png sublime-text.png
+ done
+
+ make_desktop_entry "sublime_text" "Sublime Text ${MV}" \
+ /usr/share/icons/hicolor/48x48/apps/sublime-text.png \
+ "TextEditor;IDE;Development" "StartupNotify=true"
+}
diff --git a/app-editors/sublime-text/sublime-text-3_pre3126.ebuild b/app-editors/sublime-text/sublime-text-3_pre3126.ebuild
new file mode 100644
index 000000000000..0bb29dc91437
--- /dev/null
+++ b/app-editors/sublime-text/sublime-text-3_pre3126.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils
+
+# get the major version from PV
+MV=${PV:0:1}
+MY_PV=${PV#*_pre}
+
+DESCRIPTION="Sophisticated text editor for code, markup and prose"
+HOMEPAGE="http://www.sublimetext.com"
+SRC_URI="
+ amd64? ( https://download.sublimetext.com/sublime_text_${MV}_build_${MY_PV}_x64.tar.bz2 )
+ x86? ( https://download.sublimetext.com/sublime_text_${MV}_build_${MY_PV}_x32.tar.bz2 )"
+
+LICENSE="Sublime"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ dbus? ( sys-apps/dbus )"
+
+QA_PREBUILT="*"
+S="${WORKDIR}/sublime_text_${MV}"
+
+# Sublime bundles the kitchen sink, which includes python and other assorted
+# modules. Do not try to unbundle these because you are guaranteed to fail.
+
+src_install() {
+ insinto /opt/${PN}${MV}
+ doins -r Packages
+ doins changelog.txt sublime_plugin.py sublime.py python3.3.zip
+
+ exeinto /opt/${PN}${MV}
+ doexe crash_reporter plugin_host sublime_text
+ dosym ../../opt/${PN}${MV}/sublime_text /usr/bin/sublime_text
+
+ local size
+ for size in 32 48 128 256; do
+ newicon -s ${size} Icon/${size}x${size}/sublime-text.png sublime-text.png
+ done
+
+ make_desktop_entry "sublime_text" "Sublime Text ${MV}" \
+ /usr/share/icons/hicolor/48x48/apps/sublime-text.png \
+ "TextEditor;IDE;Development" "StartupNotify=true"
+}