summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-01-25 16:58:02 +0000
committerMarek Szuba <marecki@gentoo.org>2021-01-25 17:38:02 +0000
commit6302d7b556bccc8a1d1457bddc44ce45842eb156 (patch)
tree89bb770cb97fbd6256d3aa082ab05cf71e54e648 /app-editors
parentdev-lua/luv: remove old (diff)
downloadgentoo-6302d7b556bccc8a1d1457bddc44ce45842eb156.tar.gz
gentoo-6302d7b556bccc8a1d1457bddc44ce45842eb156.tar.bz2
gentoo-6302d7b556bccc8a1d1457bddc44ce45842eb156.zip
app-editors/neovim: remove ebuilds not using Lua eclasses
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/Manifest1
-rw-r--r--app-editors/neovim/neovim-0.4.3.ebuild91
-rw-r--r--app-editors/neovim/neovim-0.4.4.ebuild103
3 files changed, 0 insertions, 195 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index 4eb16e981f8d..7b24b5f8666f 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1,2 +1 @@
-DIST neovim-0.4.3.tar.gz 9556199 BLAKE2B 831f4d4950f4fa2cd9c7393824bbb5eb571ae5759d13af9f320e0fa351fa155413a5be580f010f2c7ab43ca7bc10c569ccf6e3ba29efc7f5a035576b030b216d SHA512 e13853fa296eda8618f389c71b6cbbd6f01d561615e80cc92959131dd10e395b1c6732a7d9ef6dbb9fe3ea9da4c11485b464547e2d46b22e59b8a20214e861f5
DIST neovim-0.4.4.tar.gz 9558246 BLAKE2B b1d44898bb1e1ab40a7e1d7fb4448076c991ebe1a0956674548de82fe7a931d9eaffbf35ba03cf9c88466dcd628a55f1d7bf9e7a13f3dad74424d6d653ded60c SHA512 ca5c2fe1784ac7b0d2117948ba2e9ae5d94e36d22ff9e0967047e1e03e605537672d85543897af335103215ad462c86962f25267d352a77d61bc3d1cafb3c183
diff --git a/app-editors/neovim/neovim-0.4.3.ebuild b/app-editors/neovim/neovim-0.4.3.ebuild
deleted file mode 100644
index 55644dda6a6f..000000000000
--- a/app-editors/neovim/neovim-0.4.3.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake optfeature xdg
-
-DESCRIPTION="Vim-fork focused on extensibility and agility."
-HOMEPAGE="https://neovim.io"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/neovim/neovim.git"
-else
- SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 x86"
-fi
-
-LICENSE="Apache-2.0 vim"
-SLOT="0"
-IUSE="+luajit +nvimpager +tui"
-
-BDEPEND="
- dev-util/gperf
- virtual/libiconv
- virtual/libintl
- virtual/pkgconfig
-"
-DEPEND="
- dev-libs/libuv:0=
- >=dev-libs/libvterm-0.1.2
- dev-libs/msgpack:0=
- dev-lua/lpeg[luajit=]
- dev-lua/luv[luajit=]
- dev-lua/mpack[luajit=]
- net-libs/libnsl
- luajit? ( dev-lang/luajit:2 )
- !luajit? (
- dev-lang/lua:0=
- dev-lua/LuaBitOp
- )
- tui? (
- dev-libs/libtermkey
- >=dev-libs/unibilium-2.0.0:0=
- )
-"
-RDEPEND="
- ${DEPEND}
- app-eselect/eselect-vi
-"
-
-CMAKE_BUILD_TYPE=Release
-
-PATCHES=( "${FILESDIR}"/${P}-gcc-10-fix.patch )
-
-src_prepare() {
- # use our system vim dir
- sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
- -i src/nvim/globals.h || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DFEAT_TUI=$(usex tui)
- -DPREFER_LUA=$(usex luajit no yes)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # install a default configuration file
- insinto /etc/vim
- doins "${FILESDIR}"/sysinit.vim
-
- # conditionally install a symlink for nvimpager
- if use nvimpager; then
- dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- optfeature "clipboard support" x11-misc/xsel x11-misc/xclip gui-apps/wl-clipboard
- optfeature "Python plugin support" dev-python/pynvim
- optfeature "Ruby plugin support" dev-ruby/neovim-ruby-client
- optfeature "remote/nvr support" dev-python/neovim-remote
-}
diff --git a/app-editors/neovim/neovim-0.4.4.ebuild b/app-editors/neovim/neovim-0.4.4.ebuild
deleted file mode 100644
index b9f0be5d76b6..000000000000
--- a/app-editors/neovim/neovim-0.4.4.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake optfeature xdg
-
-DESCRIPTION="Vim-fork focused on extensibility and agility."
-HOMEPAGE="https://neovim.io"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/neovim/neovim.git"
-else
- SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 x86"
-fi
-
-LICENSE="Apache-2.0 vim"
-SLOT="0"
-IUSE="+lto +luajit +nvimpager +tui"
-# Upstream say the test library needs LuaJIT
-# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-#REQUIRED_USE="test? ( luajit )"
-#RESTRICT="!test? ( test )"
-
-BDEPEND="
- dev-util/gperf
- virtual/libiconv
- virtual/libintl
- virtual/pkgconfig
-"
-# Once dev-lua/busted has luajit support, we can add tests.
-# bug #584694
-DEPEND="
- dev-libs/libuv:0=
- >=dev-libs/libvterm-0.1.2
- dev-libs/msgpack:0=
- dev-lua/lpeg[luajit=]
- dev-lua/luv[luajit=]
- dev-lua/mpack[luajit=]
- net-libs/libnsl
- luajit? ( dev-lang/luajit:2 )
- !luajit? (
- dev-lang/lua:0=
- dev-lua/LuaBitOp
- )
- tui? (
- dev-libs/libtermkey
- >=dev-libs/unibilium-2.0.0:0=
- )
-"
-RDEPEND="
- ${DEPEND}
- app-eselect/eselect-vi
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
-)
-
-src_prepare() {
- # use our system vim dir
- sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
- -i src/nvim/globals.h || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # Upstream default to LTO on non-debug builds
- # Let's expose it as a USE flag because upstream
- # have preferences for how we should use LTO
- # if we want it on (not just -flto)
- # ... but allow turning it off.
- local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
- -DFEAT_TUI=$(usex tui)
- -DPREFER_LUA=$(usex luajit no yes)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # install a default configuration file
- insinto /etc/vim
- doins "${FILESDIR}"/sysinit.vim
-
- # conditionally install a symlink for nvimpager
- if use nvimpager; then
- dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- optfeature "clipboard support" x11-misc/xsel x11-misc/xclip gui-apps/wl-clipboard
- optfeature "Python plugin support" dev-python/pynvim
- optfeature "Ruby plugin support" dev-ruby/neovim-ruby-client
- optfeature "remote/nvr support" dev-python/neovim-remote
-}