summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMats Lidell <matsl@gentoo.org>2021-01-16 17:12:00 +0100
committerMats Lidell <matsl@gentoo.org>2021-01-16 17:13:26 +0100
commit6dbd335b119c144b07f0146c8421f8166d7d900e (patch)
tree0daadafca9802ae3d31d80d048227be3cab73545 /app-editors
parentRevert "eclass/db.eclass: use get_libname for Darwin support" (diff)
downloadgentoo-6dbd335b119c144b07f0146c8421f8166d7d900e.tar.gz
gentoo-6dbd335b119c144b07f0146c8421f8166d7d900e.tar.bz2
gentoo-6dbd335b119c144b07f0146c8421f8166d7d900e.zip
app-editors/xemacs: swallow output causing qa issue
Patch unit test to be silent in order to avoid qa issue. Bug: https://bugs.gentoo.org/764809 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mats Lidell <matsl@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xemacs/files/xemacs-21.5.34-process-test-qa.patch11
-rw-r--r--app-editors/xemacs/xemacs-21.5.34-r5.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/app-editors/xemacs/files/xemacs-21.5.34-process-test-qa.patch b/app-editors/xemacs/files/xemacs-21.5.34-process-test-qa.patch
new file mode 100644
index 000000000000..ff17f6b62411
--- /dev/null
+++ b/app-editors/xemacs/files/xemacs-21.5.34-process-test-qa.patch
@@ -0,0 +1,11 @@
+--- a/tests/automated/process-tests.el 2021-01-16 15:42:20.195864978 +0100
++++ b/tests/automated/process-tests.el 2021-01-16 15:43:27.840426754 +0100
+@@ -49,7 +49,7 @@
+ (goto-char (point-min))
+ (Assert (looking-at "foo"))):
+
+- (Assert (= 127 (shell-command "unknown_command")))
++ (Assert (= 127 (shell-command "unknown_command > /dev/null 2>&1")))
+ (Assert (= 2 (shell-command "exit 2")))
+ (Assert (equal "(Shell command failed with code 2 and no output)" (message-displayed-p t)))
+
diff --git a/app-editors/xemacs/xemacs-21.5.34-r5.ebuild b/app-editors/xemacs/xemacs-21.5.34-r5.ebuild
index accb1cfdff36..91fe80f8bfe7 100644
--- a/app-editors/xemacs/xemacs-21.5.34-r5.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.34-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Note: xemacs currently does not work with position independent code
@@ -70,6 +70,7 @@ src_prepare() {
eapply "${FILESDIR}/${P}-configure-libc-version.patch"
eapply "${FILESDIR}/${P}-ar.patch"
eapply "${FILESDIR}/${P}-strsignal.patch"
+ eapply "${FILESDIR}/${P}-process-test-qa.patch"
eapply_user