summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-19 03:31:25 +0000
committerSam James <sam@gentoo.org>2021-01-19 03:31:25 +0000
commit7d236a315dd7fb66ed292f881cdc43d2a72de805 (patch)
tree86d7b0d1db1a7b33310c153cde8edadb106aa71d /app-editors
parentapp-arch/wimlib: bump to 1.13.3 (diff)
downloadgentoo-7d236a315dd7fb66ed292f881cdc43d2a72de805.tar.gz
gentoo-7d236a315dd7fb66ed292f881cdc43d2a72de805.tar.bz2
gentoo-7d236a315dd7fb66ed292f881cdc43d2a72de805.zip
app-editors/neovim: explicitly mark Gentoo build type as OK
No revbump because it's a minor change. Please re-install to pick it up if you're interested. This is completely cosmetic - the Gentoo build is already optimised and NOT debug, but this fixes the warning in :checkhealth. Closes: https://bugs.gentoo.org/757744 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch13
-rw-r--r--app-editors/neovim/neovim-0.4.4-r100.ebuild5
-rw-r--r--app-editors/neovim/neovim-0.4.4.ebuild6
-rw-r--r--app-editors/neovim/neovim-9999.ebuild5
4 files changed, 24 insertions, 5 deletions
diff --git a/app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch b/app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch
new file mode 100644
index 000000000000..2c9c80a7a690
--- /dev/null
+++ b/app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch
@@ -0,0 +1,13 @@
+Ensure that :checkhealth is happy with the Gentoo build type.
+https://bugs.gentoo.org/757744
+--- a/runtime/autoload/health/nvim.vim
++++ b/runtime/autoload/health/nvim.vim
+@@ -118,7 +118,7 @@ function! s:check_performance() abort
+ let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
+ if empty(buildtype)
+ call health#report_error('failed to get build type from :version')
+- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
++ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
+ call health#report_ok(buildtype)
+ else
+ call health#report_info(buildtype)
diff --git a/app-editors/neovim/neovim-0.4.4-r100.ebuild b/app-editors/neovim/neovim-0.4.4-r100.ebuild
index 8cd8499a6fa2..2fdf25560fce 100644
--- a/app-editors/neovim/neovim-0.4.4-r100.ebuild
+++ b/app-editors/neovim/neovim-0.4.4-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -61,7 +61,8 @@ RDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-0.4.4-cmake_lua_version.patch
+ "${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
+ "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
)
src_prepare() {
diff --git a/app-editors/neovim/neovim-0.4.4.ebuild b/app-editors/neovim/neovim-0.4.4.ebuild
index 2b8b289784e9..b9f0be5d76b6 100644
--- a/app-editors/neovim/neovim-0.4.4.ebuild
+++ b/app-editors/neovim/neovim-0.4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -55,6 +55,10 @@ RDEPEND="
app-eselect/eselect-vi
"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
+)
+
src_prepare() {
# use our system vim dir
sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index d10ac87a1704..0663ee9e4715 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -63,7 +63,8 @@ RDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-0.4.4-cmake_lua_version.patch
+ "${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
+ "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
)
src_prepare() {