summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-20 01:34:21 +0100
committerSam James <sam@gentoo.org>2021-04-20 02:20:28 +0100
commit86800841556927c5a4a436475efb1839d73c5c5e (patch)
tree35b5e999ad43c3271d64af1e60e8cde5777d1b4f /app-editors
parentapp-editors/levee: port to EAPI 7 (diff)
downloadgentoo-86800841556927c5a4a436475efb1839d73c5c5e.tar.gz
gentoo-86800841556927c5a4a436475efb1839d73c5c5e.tar.bz2
gentoo-86800841556927c5a4a436475efb1839d73c5c5e.zip
app-editors/hexedit: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/hexedit/hexedit-1.2.13.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/app-editors/hexedit/hexedit-1.2.13.ebuild b/app-editors/hexedit/hexedit-1.2.13.ebuild
index 10627d3f7c55..d0b42fcc75f5 100644
--- a/app-editors/hexedit/hexedit-1.2.13.ebuild
+++ b/app-editors/hexedit/hexedit-1.2.13.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools epatch
+EAPI=7
+
+inherit autotools
DESCRIPTION="View and edit files in hex or ASCII"
HOMEPAGE="http://rigaux.org/hexedit.html"
@@ -15,10 +16,15 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~s390 sparc x86 ~amd64-li
DEPEND="sys-libs/ncurses:="
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}"/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
+ default
+
mv configure.in configure.ac || die
eautoreconf
}