summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 14:19:39 +0100
committerSam James <sam@gentoo.org>2022-10-04 14:26:19 +0100
commit971d2367313f4fc511c242d3b9903f2178208768 (patch)
treea9a9947e5b0e4341863fc1372182ace8f6f0b52b /app-editors
parentapp-editors/vim: drop 8.2.4586-r1, 8.2.5066-r2, 9.0.0049-r1 (diff)
downloadgentoo-971d2367313f4fc511c242d3b9903f2178208768.tar.gz
gentoo-971d2367313f4fc511c242d3b9903f2178208768.tar.bz2
gentoo-971d2367313f4fc511c242d3b9903f2178208768.zip
app-editors/vim: fix IndirectInherits, sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/vim-9.0.0099-r1.ebuild2
-rw-r--r--app-editors/vim/vim-9999.ebuild12
2 files changed, 11 insertions, 3 deletions
diff --git a/app-editors/vim/vim-9.0.0099-r1.ebuild b/app-editors/vim/vim-9.0.0099-r1.ebuild
index 7b427e86607f..512001925c59 100644
--- a/app-editors/vim/vim-9.0.0099-r1.ebuild
+++ b/app-editors/vim/vim-9.0.0099-r1.ebuild
@@ -11,7 +11,7 @@ PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
USE_RUBY="ruby27 ruby30 ruby31"
-inherit vim-doc flag-o-matic bash-completion-r1 lua-single python-single-r1 ruby-single desktop xdg-utils
+inherit vim-doc flag-o-matic bash-completion-r1 lua-single python-single-r1 ruby-single toolchain-funcs desktop xdg-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index cfbe30fe984c..5ffcda64baac 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -11,7 +11,7 @@ PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
USE_RUBY="ruby27 ruby30 ruby31"
-inherit vim-doc flag-o-matic bash-completion-r1 lua-single python-single-r1 ruby-single desktop xdg-utils
+inherit vim-doc flag-o-matic bash-completion-r1 lua-single python-single-r1 ruby-single toolchain-funcs desktop xdg-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -78,7 +78,7 @@ src_prepare() {
if [[ ${PV} != 9999* ]] ; then
# Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}/vim-patches-vim-9.0.0049-patches"
+ eapply "${WORKDIR}"/vim-patches-vim-9.0.0049-patches
fi
# Fixup a script to use awk instead of nawk
@@ -250,6 +250,14 @@ src_configure() {
# keep prefix env contained within the EPREFIX
use prefix && myconf+=( --without-local-dir )
+ if tc-is-cross-compiler ; then
+ export vim_cv_getcwd_broken=no \
+ vim_cv_memmove_handles_overlap=yes \
+ vim_cv_stat_ignores_slash=yes \
+ vim_cv_terminfo=yes \
+ vim_cv_toupper_broken=no
+ fi
+
econf \
--with-modified-by=Gentoo-${PVR} \
"${myconf[@]}"