summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-29 13:44:53 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-29 13:47:14 -0500
commit9aad551a8ad2a1f1a1328df225fca8df7e9930f9 (patch)
tree0dacce2e921f3a9a2226aa77641d65be36419c9a /app-editors
parentapp-emulation/qemu: version bump to 2.7.1 (diff)
downloadgentoo-9aad551a8ad2a1f1a1328df225fca8df7e9930f9.tar.gz
gentoo-9aad551a8ad2a1f1a1328df225fca8df7e9930f9.tar.bz2
gentoo-9aad551a8ad2a1f1a1328df225fca8df7e9930f9.zip
app-editors/nano: add upstream fix for USE=minimal builds #604000
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/files/nano-2.7.3-tiny.patch29
-rw-r--r--app-editors/nano/nano-2.7.3.ebuild1
2 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/nano/files/nano-2.7.3-tiny.patch b/app-editors/nano/files/nano-2.7.3-tiny.patch
new file mode 100644
index 000000000000..148716d5db7b
--- /dev/null
+++ b/app-editors/nano/files/nano-2.7.3-tiny.patch
@@ -0,0 +1,29 @@
+From fc89ac11d25a5d052a63c01006c1fd767d9f5879 Mon Sep 17 00:00:00 2001
+From: Felix Janda <felix.janda@posteo.de>
+Date: Thu, 29 Dec 2016 13:43:06 -0500
+Subject: [PATCH] speller: fix build when tiny build is enabled
+
+URL: https://bugs.gentoo.org/604000
+---
+ src/text.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/text.c b/src/text.c
+index bd1737687e65..a8b34f2f6bba 100644
+--- a/src/text.c
++++ b/src/text.c
+@@ -3079,9 +3079,11 @@ const char *do_alt_speller(char *tempfile_name)
+ stat(tempfile_name, &spellfileinfo);
+ if (spellfileinfo.st_mtime != timestamp) {
+ set_modified();
++#ifndef NANO_TINY
+ /* Flush the undo stack, to avoid making a mess when the user
+ * tries to undo things in spell-corrected lines. */
+ discard_until(NULL, openfile);
++#endif
+ }
+ #ifndef NANO_TINY
+ /* Unblock SIGWINCHes again. */
+--
+2.11.0
+
diff --git a/app-editors/nano/nano-2.7.3.ebuild b/app-editors/nano/nano-2.7.3.ebuild
index ea75851bd6a5..26259bc64c99 100644
--- a/app-editors/nano/nano-2.7.3.ebuild
+++ b/app-editors/nano/nano-2.7.3.ebuild
@@ -35,6 +35,7 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
eautoreconf
fi
+ epatch "${FILESDIR}"/${P}-tiny.patch #604000
epatch_user
}