summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2017-04-12 02:44:19 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-07 20:29:08 +0200
commitb25230c9155672bbc1a7400a5a8515350269dfef (patch)
treeb77d66c18c29dcf58fdf020ce9a7410accefc1c7 /app-editors
parentsys-devel/gdb: add missing DEPEND on texinfo (diff)
downloadgentoo-b25230c9155672bbc1a7400a5a8515350269dfef.tar.gz
gentoo-b25230c9155672bbc1a7400a5a8515350269dfef.tar.bz2
gentoo-b25230c9155672bbc1a7400a5a8515350269dfef.zip
app-editors/vis: new package, #613820
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vis/Manifest1
-rw-r--r--app-editors/vis/metadata.xml17
-rw-r--r--app-editors/vis/vis-0.3.ebuild39
-rw-r--r--app-editors/vis/vis-9999.ebuild40
4 files changed, 97 insertions, 0 deletions
diff --git a/app-editors/vis/Manifest b/app-editors/vis/Manifest
new file mode 100644
index 000000000000..e097689917e4
--- /dev/null
+++ b/app-editors/vis/Manifest
@@ -0,0 +1 @@
+DIST vis-0.3.tar.gz 334216 SHA256 bed8ed32ef4f81bc4fd28e297ea8edc80027ac6923b9d3b5bd955d24899c7077 SHA512 e1ca009bd7569f22dacf7464791f9f4499695d15d6e38e1be491d39e7ebe0530de643be5c1e7647e9beb7969a17efab6545d3e719fe8cf311562e89d636bba62 WHIRLPOOL a0ddd69b88b4131d4b9c2ba5494e255f20cd99f91998e4ad4fcec3e0298e39d9319571201b8ae4c8b4d21da78b99d865d72bfb534024a89863d66b9968e562c8
diff --git a/app-editors/vis/metadata.xml b/app-editors/vis/metadata.xml
new file mode 100644
index 000000000000..0226bf9ceda3
--- /dev/null
+++ b/app-editors/vis/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>contact@hacktivis.me</email>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+<longdescription lang="en">
+Vis aims to be a modern, legacy free, simple yet efficient editor combining the strengths of both vi(m) and sam.
+</longdescription>
+<use>
+ <flag name="tre">more memory efficient regex search using <pkg>dev-libs/tre</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/app-editors/vis/vis-0.3.ebuild b/app-editors/vis/vis-0.3.ebuild
new file mode 100644
index 000000000000..e6ef1b663060
--- /dev/null
+++ b/app-editors/vis/vis-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
+HOMEPAGE="https://github.com/martanne/vis"
+SRC_URI="https://github.com/martanne/vis/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ncurses selinux tre"
+
+#Note: vis is reported to also work with NetBSD curses
+#TODO: >=dev-lang/lua-5.2 (needed for syntax highlighting and settings)
+DEPEND=" dev-libs/libtermkey
+ ncurses? ( sys-libs/ncurses:0= )
+ tre? ( dev-libs/tre:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable ncurses curses) \
+ $(use_enable selinux) \
+ $(use_enable tre)
+}
+
+update_symlinks() {
+ einfo "Calling eselect vi update --if-unset…"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ update_symlinks
+}
+
+pkg_postinst() {
+ update_symlinks
+}
diff --git a/app-editors/vis/vis-9999.ebuild b/app-editors/vis/vis-9999.ebuild
new file mode 100644
index 000000000000..55adf2006010
--- /dev/null
+++ b/app-editors/vis/vis-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit git-r3
+
+DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
+HOMEPAGE="https://github.com/martanne/vis"
+EGIT_REPO_URI="https://github.com/martanne/vis.git"
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS=""
+IUSE="+ncurses selinux tre"
+
+#Note: vis is reported to also work with NetBSD curses
+#TODO: >=dev-lang/lua-5.2 (needed for syntax highlighting and settings)
+DEPEND=" dev-libs/libtermkey
+ ncurses? ( sys-libs/ncurses:0= )
+ tre? ( dev-libs/tre:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable ncurses curses) \
+ $(use_enable selinux) \
+ $(use_enable tre)
+}
+
+update_symlinks() {
+ einfo "Calling eselect vi update --if-unset…"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ update_symlinks
+}
+
+pkg_postinst() {
+ update_symlinks
+}