summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-11-03 17:14:53 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-03 09:59:20 +0200
commitd381ac05a62802104385f955708720a588a0054c (patch)
tree96fdf790fe3a0e9f7b5f54b361829a15c15ffe86 /app-editors
parentdev-python/mediafile: cleanup old (diff)
downloadgentoo-d381ac05a62802104385f955708720a588a0054c.tar.gz
gentoo-d381ac05a62802104385f955708720a588a0054c.tar.bz2
gentoo-d381ac05a62802104385f955708720a588a0054c.zip
app-editors/vis: Add lua support
Mostly based on prior work comitted into ::lua repository Closes: https://bugs.gentoo.org/752540 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/18120 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vis/vis-0.6.ebuild10
-rw-r--r--app-editors/vis/vis-9999.ebuild11
2 files changed, 14 insertions, 7 deletions
diff --git a/app-editors/vis/vis-0.6.ebuild b/app-editors/vis/vis-0.6.ebuild
index 7a2ce6eaaa69..b624dd79c35c 100644
--- a/app-editors/vis/vis-0.6.ebuild
+++ b/app-editors/vis/vis-0.6.ebuild
@@ -4,6 +4,9 @@
EAPI=7
MY_PTV=0.4
+LUA_COMPAT=( lua5-2 lua5-3 )
+
+inherit lua-single eutils
DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
HOMEPAGE="https://github.com/martanne/vis"
@@ -12,14 +15,13 @@ SRC_URI="https://github.com/martanne/vis/releases/download/v${PV}/${P}.tar.gz
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+ncurses selinux test tre"
+IUSE="+ncurses +lua selinux test tre"
RESTRICT="!test? ( test )"
# - Known to also work with NetBSD curses
-# - ::lua package done for using >=dev-lang/lua-5.2
-# which is needed for syntax highlighting and settings but masked in ::gentoo
DEPEND="dev-libs/libtermkey
ncurses? ( sys-libs/ncurses:0= )
+ lua? ( ${LUA_DEPS} )
tre? ( dev-libs/tre:= )"
RDEPEND="${DEPEND}
app-eselect/eselect-vi"
@@ -44,6 +46,7 @@ src_configure() {
./configure \
--prefix="${EPREFIX}"/usr \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable lua) \
$(use_enable ncurses curses) \
$(use_enable selinux) \
$(use_enable tre) || die
@@ -60,4 +63,5 @@ pkg_postrm() {
pkg_postinst() {
update_symlinks
+ optfeature "syntax highlighting support" dev-lua/lpeg
}
diff --git a/app-editors/vis/vis-9999.ebuild b/app-editors/vis/vis-9999.ebuild
index 600b5efb0576..7af054d1607e 100644
--- a/app-editors/vis/vis-9999.ebuild
+++ b/app-editors/vis/vis-9999.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3
+LUA_COMPAT=( lua5-2 lua5-3 )
+
+inherit lua-single git-r3 eutils
DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
HOMEPAGE="https://github.com/martanne/vis"
@@ -10,14 +12,13 @@ EGIT_REPO_URI="https://github.com/martanne/vis.git"
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE="+ncurses selinux test tre"
+IUSE="+ncurses +lua selinux test tre"
RESTRICT="!test? ( test )"
# - Known to also work with NetBSD curses
-# - ::lua package done for using >=dev-lang/lua-5.2
-# which is needed for syntax highlighting and settings but masked in ::gentoo
DEPEND="dev-libs/libtermkey
ncurses? ( sys-libs/ncurses:0= )
+ lua? ( ${LUA_DEPS} )
tre? ( dev-libs/tre:= )"
RDEPEND="${DEPEND}
app-eselect/eselect-vi"
@@ -34,6 +35,7 @@ src_configure() {
./configure \
--prefix="${EPREFIX}"/usr \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable lua) \
$(use_enable ncurses curses) \
$(use_enable selinux) \
$(use_enable tre) || die
@@ -50,4 +52,5 @@ pkg_postrm() {
pkg_postinst() {
update_symlinks
+ optfeature "syntax highlighting support" dev-lua/lpeg
}