summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2023-01-11 23:13:16 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-01-28 10:43:48 +0200
commitd6e41c39dca67ba217ac1366cc9a8a05e1fc1274 (patch)
treecc784143279ce7103f7b521ea4c9930d371777a7 /app-editors
parentnet-im/pidgin: update metadata.xml (diff)
downloadgentoo-d6e41c39dca67ba217ac1366cc9a8a05e1fc1274.tar.gz
gentoo-d6e41c39dca67ba217ac1366cc9a8a05e1fc1274.tar.bz2
gentoo-d6e41c39dca67ba217ac1366cc9a8a05e1fc1274.zip
app-editors/retext: add 8.0.0
From version 8.0.0 ReText uses PyQt6 and optionally PyQt6-WebEngine, therefore mask >=app-editors/retext-8.0.0 since dev-python/PyQt6 is also masked. Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/retext/Manifest1
-rw-r--r--app-editors/retext/retext-8.0.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-editors/retext/Manifest b/app-editors/retext/Manifest
index 170590d8d240..0011fc4e7d01 100644
--- a/app-editors/retext/Manifest
+++ b/app-editors/retext/Manifest
@@ -1,2 +1,3 @@
DIST ReText-7.2.2.tar.gz 522652 BLAKE2B f9b19f985c1381eade324758c4dc6bf2e5f74bc3f5bfc27afa10462b7387f64a3e72edd5875aabf1831f1f0a942f395e43b124c172cac8cec4b9f19334661484 SHA512 68345b57b2c5446158ed3a6f97b5ead103ef1c99a3aea9cbc69ef7d0807fb64546f38ebde2969b94429eeed6450abb345fecc566dcf6e0767fe84c4e27348e53
DIST ReText-7.2.3.tar.gz 527428 BLAKE2B 3c710769a881275d74018ba319b174020dda0b65da22ae926231af56901b56c31b3cff69119a9bb378cd218d7b793f002bb08bf1483cc1e55c95a4963cbe1598 SHA512 eb337866f5dfacad2f23435f09b550f4378df5bb261d6f79b1708fed9e7bd93e96e8f06f940cb7109fe02aa6df0592b151f11dfe13853799f0b1ac2c1065a0da
+DIST ReText-8.0.0.tar.gz 492823 BLAKE2B ba80f01f1a40981220c0b3e16dd04bf551319a35c1a5c7f6d5e70135404537e74fa4625fe4c05c7ee54202de9ae16d181c110fcae9b9172761ca5ecf6400f7de SHA512 0f2480bcc8569cf60ebfe55847a2a068d1e5dd262a4ff212873bf58660ec31e9c37d9b21bdc66229d681c065a0d96b6ff11652e8d9a7c77841ea551480d1154c
diff --git a/app-editors/retext/retext-8.0.0.ebuild b/app-editors/retext/retext-8.0.0.ebuild
new file mode 100644
index 000000000000..8ed93a38001b
--- /dev/null
+++ b/app-editors/retext/retext-8.0.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please don't add pypy support before testing if it's actually supported. The
+# old compat matrix is no longer accessible as of 2021-02-13 but stated back
+# in 2020-07-05 that PyQt5 was explicitly not supported.
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1 optfeature qmake-utils virtualx xdg
+
+MY_PN="ReText"
+MY_P="${MY_PN}-${PV/_/~}"
+
+DESCRIPTION="Simple editor for Markdown and reStructuredText"
+HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ >=dev-python/markups-3.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/PyQt6[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools
+ test? ( dev-python/PyQt6[testlib,${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+pkg_setup() {
+ # Needed for lrelease
+ export PATH="$(qt5_get_bindir):${PATH}"
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ virtx eunittest
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "dictionary support" dev-python/pyenchant
+ # See https://bugs.gentoo.org/772197.
+ optfeature "rendering with webengine" dev-python/PyQt6-WebEngine
+
+ einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
+ einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
+ einfo "For more details take a look at:"
+ einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
+}