summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-02-22 09:07:10 +0100
committerUlrich Müller <ulm@gentoo.org>2018-02-22 09:07:27 +0100
commite20442516052acb398831a7cc83b0d1295c670d2 (patch)
tree61211012a3b248a42b5a1044f3d12277740eb2e9 /app-editors
parentapp-editors/emacs: Use env instead of a wrapper script. (diff)
downloadgentoo-e20442516052acb398831a7cc83b0d1295c670d2.tar.gz
gentoo-e20442516052acb398831a7cc83b0d1295c670d2.tar.bz2
gentoo-e20442516052acb398831a7cc83b0d1295c670d2.zip
app-editors/emacs-vcs: Use env instead of a wrapper script.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild10
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild10
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild10
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild10
4 files changed, 4 insertions, 36 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild b/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild
index b332683366c3..b77e6ec42e35 100644
--- a/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild
@@ -274,15 +274,7 @@ src_configure() {
src_compile() {
# Disable sandbox when dumping. For the unbelievers, see bug #131505
- cat >src/temacs-wrapper <<-'EOF' || die
- #!/bin/bash
- export SANDBOX_ON=0
- unset LD_PRELOAD
- exec ./temacs "$@"
- EOF
- chmod +x src/temacs-wrapper || die
-
- emake RUN_TEMACS="./temacs-wrapper"
+ emake RUN_TEMACS="env SANDBOX_ON=0 LD_PRELOAD= ./temacs"
}
src_install () {
diff --git a/app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild b/app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild
index b332683366c3..b77e6ec42e35 100644
--- a/app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild
@@ -274,15 +274,7 @@ src_configure() {
src_compile() {
# Disable sandbox when dumping. For the unbelievers, see bug #131505
- cat >src/temacs-wrapper <<-'EOF' || die
- #!/bin/bash
- export SANDBOX_ON=0
- unset LD_PRELOAD
- exec ./temacs "$@"
- EOF
- chmod +x src/temacs-wrapper || die
-
- emake RUN_TEMACS="./temacs-wrapper"
+ emake RUN_TEMACS="env SANDBOX_ON=0 LD_PRELOAD= ./temacs"
}
src_install () {
diff --git a/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild b/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild
index b332683366c3..b77e6ec42e35 100644
--- a/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild
@@ -274,15 +274,7 @@ src_configure() {
src_compile() {
# Disable sandbox when dumping. For the unbelievers, see bug #131505
- cat >src/temacs-wrapper <<-'EOF' || die
- #!/bin/bash
- export SANDBOX_ON=0
- unset LD_PRELOAD
- exec ./temacs "$@"
- EOF
- chmod +x src/temacs-wrapper || die
-
- emake RUN_TEMACS="./temacs-wrapper"
+ emake RUN_TEMACS="env SANDBOX_ON=0 LD_PRELOAD= ./temacs"
}
src_install () {
diff --git a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
index 9cf901fe95f7..75f4324cd896 100644
--- a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
@@ -274,15 +274,7 @@ src_configure() {
src_compile() {
# Disable sandbox when dumping. For the unbelievers, see bug #131505
- cat >src/temacs-wrapper <<-'EOF' || die
- #!/bin/bash
- export SANDBOX_ON=0
- unset LD_PRELOAD
- exec ./temacs "$@"
- EOF
- chmod +x src/temacs-wrapper || die
-
- emake RUN_TEMACS="./temacs-wrapper"
+ emake RUN_TEMACS="env SANDBOX_ON=0 LD_PRELOAD= ./temacs"
}
src_install () {