summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-23 09:47:54 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-23 09:48:03 +0100
commitf06a09623408b03131890042efcafc84c203be7c (patch)
tree054f1b4b08705aa49e695954dcf6e1e4b95154da /app-editors
parentnet-misc/rsync: Bump to version 3.2.1. Removed old (diff)
downloadgentoo-f06a09623408b03131890042efcafc84c203be7c.tar.gz
gentoo-f06a09623408b03131890042efcafc84c203be7c.tar.bz2
gentoo-f06a09623408b03131890042efcafc84c203be7c.zip
app-editors/hteditor: force -std=c++98
Workaround build failure on clang by downgrading doen to C++ 98. Reported-by: Agostino Sarubbo Bug: https://bugs.gentoo.org/729252 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/hteditor/hteditor-2.1.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild b/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
index 16a7ab4322f0..5b912857bc6f 100644
--- a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
+++ b/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
MY_P=${P/editor}
@@ -39,6 +39,12 @@ PATCHES=(
src_prepare() {
default
eautoreconf
+
+ # Many literals are concatenated with macro definitions.
+ # Instead of patching them all let's pick old c++ standard
+ # and port to c++11 upstream.
+ # https://bugs.gentoo.org/729252
+ append-cxxflags -std=c++98
}
src_configure() {