summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-09-05 12:24:13 +0200
committerUlrich Müller <ulm@gentoo.org>2019-09-05 12:26:40 +0200
commit6bf543064ee636fee7842bf3000b8c861db458c8 (patch)
tree3369a45c60f190f850d4f4bb5cf270736c618f79 /app-emacs/auctex
parentapp-emacs/quilt-el: Bump to version 0.66. (diff)
downloadgentoo-6bf543064ee636fee7842bf3000b8c861db458c8.tar.gz
gentoo-6bf543064ee636fee7842bf3000b8c861db458c8.tar.bz2
gentoo-6bf543064ee636fee7842bf3000b8c861db458c8.zip
app-emacs/auctex: Fix build failure with Emacs 27.
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/auctex')
-rw-r--r--app-emacs/auctex/auctex-12.1-r1.ebuild62
-rw-r--r--app-emacs/auctex/files/auctex-12.1-autoload.patch33
2 files changed, 95 insertions, 0 deletions
diff --git a/app-emacs/auctex/auctex-12.1-r1.ebuild b/app-emacs/auctex/auctex-12.1-r1.ebuild
new file mode 100644
index 000000000000..dcd803eff7f9
--- /dev/null
+++ b/app-emacs/auctex/auctex-12.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Extensible package for writing and formatting TeX files in Emacs"
+HOMEPAGE="https://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="preview-latex"
+
+RDEPEND="virtual/latex-base
+ preview-latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ )"
+BDEPEND="${RDEPEND}"
+
+ELISP_PATCHES="${P}-autoload.patch"
+TEXMF="/usr/share/texmf-site"
+
+src_configure() {
+ econf --with-emacs \
+ --with-auto-dir="${EPREFIX}/var/lib/auctex" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
+ --with-texmf-dir="${EPREFIX}${TEXMF}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-build-dir-test \
+ $(use_enable preview-latex preview)
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
+ fi
+ dodoc ChangeLog* CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
+}
+
+pkg_postinst() {
+ use preview-latex && texmf-update
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && texmf-update
+ elisp-site-regen
+}
diff --git a/app-emacs/auctex/files/auctex-12.1-autoload.patch b/app-emacs/auctex/files/auctex-12.1-autoload.patch
new file mode 100644
index 000000000000..3ee765d94ca2
--- /dev/null
+++ b/app-emacs/auctex/files/auctex-12.1-autoload.patch
@@ -0,0 +1,33 @@
+commit 1b88eda687913a3a355a010ed0483bfcfce28301
+Author: Tassilo Horn <tsdh@gnu.org>
+Date: Fri May 17 22:07:10 2019 +0200
+
+ Fix autoload generation code (bug#35758)
+
+ * Makefile.in (AUTOLOAD,PREVIEW_AUTOLOAD): Use arg instead of
+ generated-autoload-file (bug#35758).
+
+diff --git a/Makefile.in b/Makefile.in
+index 822eea9f..74659f7a 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -52,12 +52,15 @@ PACKAGE=auctex
+ PACKAGE_INFO=auctex preview-latex
+ EMACS=@EMACS@
+ ELCC=$(EMACS) -batch -q -no-site-file -no-init-file -l lpath.el
+-AUTOLOAD=--eval '(let ((generated-autoload-file (expand-file-name "$@"))) \
+- (mapcar (function update-file-autoloads) command-line-args-left) \
++AUTOLOAD=--eval '(let ((autoload-file (expand-file-name "$@"))) \
++ (mapcar (lambda (file) \
++ (update-file-autoloads file nil autoload-file)) \
++ command-line-args-left) \
+ (save-buffers-kill-emacs t))'
+
+-PREVIEW_AUTOLOAD=--eval '(let ((generated-autoload-file (expand-file-name "$@"))) \
+- (update-file-autoloads "preview.el")(save-buffers-kill-emacs t))'
++PREVIEW_AUTOLOAD=--eval '(let ((autoload-file (expand-file-name "$@"))) \
++ (update-file-autoloads "preview.el" nil autoload-file) \
++ (save-buffers-kill-emacs t))'
+
+ # Files and directories excluded from distributed tar ball.
+ EXCLUDEDFILES=autogen.sh .gitignore doc/.gitignore doc/tex-ref.log \