summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/ebuild-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/ebuild-mode')
-rw-r--r--app-emacs/ebuild-mode/Manifest1
-rw-r--r--app-emacs/ebuild-mode/ebuild-mode-1.27.ebuild21
-rw-r--r--app-emacs/ebuild-mode/files/50ebuild-mode-gentoo.el13
-rw-r--r--app-emacs/ebuild-mode/metadata.xml5
4 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/ebuild-mode/Manifest b/app-emacs/ebuild-mode/Manifest
new file mode 100644
index 000000000000..8b6f3ce95cf2
--- /dev/null
+++ b/app-emacs/ebuild-mode/Manifest
@@ -0,0 +1 @@
+DIST ebuild-mode-1.27.tar.xz 29040 SHA256 06b682c5132f513d1a22ad96beca8bbb7d632aa73b094cc79cd1109c7a5bcfe2 SHA512 7f8608f66bb5fd665059019cccbae4729e1fd3389628428c8c83d0a8694b3de78217da255b5858c91df40925c7c859d1cb1806adf98f97c2441c6e71444713ec WHIRLPOOL 364f35d89c8137f6c6c9c257a99780e69dce93cd077b9e12ef4944c924f042fb3bc1da9fddae08ede385f3faf13e5c22533c5a566ce891ff93d39bae758a7b62
diff --git a/app-emacs/ebuild-mode/ebuild-mode-1.27.ebuild b/app-emacs/ebuild-mode/ebuild-mode-1.27.ebuild
new file mode 100644
index 000000000000..f5b6af02a2b7
--- /dev/null
+++ b/app-emacs/ebuild-mode/ebuild-mode-1.27.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="http://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DOCS="ChangeLog keyword-generation.sh"
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="Some optional features may require installation of additional
+ packages, like app-portage/gentoolkit-dev for echangelog."
diff --git a/app-emacs/ebuild-mode/files/50ebuild-mode-gentoo.el b/app-emacs/ebuild-mode/files/50ebuild-mode-gentoo.el
new file mode 100644
index 000000000000..44b3bdb23ec2
--- /dev/null
+++ b/app-emacs/ebuild-mode/files/50ebuild-mode-gentoo.el
@@ -0,0 +1,13 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ebuild-mode "ebuild-mode"
+ "Major mode for Portage .ebuild and .eclass files." t)
+(autoload 'gentoo-newsitem-mode "gentoo-newsitem-mode"
+ "Major mode for Gentoo GLEP 42 news items." t)
+
+(add-to-list 'auto-mode-alist
+ '("\\.\\(ebuild\\|eclass\\|eblit\\)\\'" . ebuild-mode))
+(add-to-list 'auto-mode-alist
+ '("/[0-9]\\{4\\}-[01][0-9]-[0-3][0-9]-.+\\.[a-z]\\{2\\}\\.txt\\'"
+ . gentoo-newsitem-mode))
+(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode))
+(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\|eblit\\)\\'" 'utf-8)
diff --git a/app-emacs/ebuild-mode/metadata.xml b/app-emacs/ebuild-mode/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/ebuild-mode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>