summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/emacs-wiki
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/emacs-wiki')
-rw-r--r--app-emacs/emacs-wiki/Manifest1
-rw-r--r--app-emacs/emacs-wiki/emacs-wiki-2.72-r2.ebuild42
-rw-r--r--app-emacs/emacs-wiki/files/50emacs-wiki-gentoo.el5
-rw-r--r--app-emacs/emacs-wiki/metadata.xml21
4 files changed, 69 insertions, 0 deletions
diff --git a/app-emacs/emacs-wiki/Manifest b/app-emacs/emacs-wiki/Manifest
new file mode 100644
index 000000000000..7e17a51ab1eb
--- /dev/null
+++ b/app-emacs/emacs-wiki/Manifest
@@ -0,0 +1 @@
+DIST emacs-wiki-2.72.tar.gz 217896 SHA256 66d39fbae5020d2936fbfae754f34415fff3ed8fb5f3f4b97c8bdfddbb81b5c5 SHA512 eed759f43c8ba6bb06be2d6b5ab3eef4f13593ce952402dc0d054ff7283b236ded789807b080d19c06857367385dcbf76aec440ebbd7e2a23b113ddb4d288cb7 WHIRLPOOL 6ef71f14e2cd324bbcfdf951612c75812631291e9d00172f47e9d72581492149795fd0cc0504d9376041096287dceb23f8fb2a524c1cfc06b3eb5183def1f774
diff --git a/app-emacs/emacs-wiki/emacs-wiki-2.72-r2.ebuild b/app-emacs/emacs-wiki/emacs-wiki-2.72-r2.ebuild
new file mode 100644
index 000000000000..587cde02ed1c
--- /dev/null
+++ b/app-emacs/emacs-wiki/emacs-wiki-2.72-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Maintain a local Wiki using Emacs-friendly markup"
+HOMEPAGE="http://www.mwolson.org/projects/EmacsWiki.html
+ http://www.emacswiki.org/emacs/EmacsWikiMode"
+SRC_URI="http://www.mwolson.org/static/dist/emacs-wiki/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-emacs/htmlize
+ app-emacs/httpd"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ # These will be made part of the emacs-wiki installation until
+ # they are packaged separately
+ mv "${S}"/contrib/{update-remote,cgi}.el "${S}"/ || die
+}
+
+src_compile() {
+ elisp-compile *.el
+ makeinfo emacs-wiki.texi || die "makeinfo failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo *.info*
+ dodoc README ChangeLog*
+ docinto examples
+ dodoc examples/default.css
+}
diff --git a/app-emacs/emacs-wiki/files/50emacs-wiki-gentoo.el b/app-emacs/emacs-wiki/files/50emacs-wiki-gentoo.el
new file mode 100644
index 000000000000..487d5ddeecce
--- /dev/null
+++ b/app-emacs/emacs-wiki/files/50emacs-wiki-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'emacs-wiki-mode "emacs-wiki"
+ "An Emacs mode for maintaining a local Wiki database." t)
+(autoload 'emacs-wiki-find-file "emacs-wiki"
+ "Open the Emacs Wiki page WIKI by name." t)
diff --git a/app-emacs/emacs-wiki/metadata.xml b/app-emacs/emacs-wiki/metadata.xml
new file mode 100644
index 000000000000..fd8b7e6425eb
--- /dev/null
+++ b/app-emacs/emacs-wiki/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+Emacs-wiki allows you to create a wiki on your local system and export
+HTML pages.
+
+Emacs-wiki has many uses. It has been used to organize links. It can
+make web page maintenance and design a lot easier. It is used as the
+back-end of Planner. You can store and link together various bits of
+information in a coherent manner. A weblog of sorts can be made with
+it, but RSS syndication is not supported.
+
+Emacs-wiki is not a real wiki in its basic configuration, because
+users from the web cannot edit the pages unless you use
+emacs-wiki-httpd.el .
+
+Emacs-wiki does not allow you to edit the pages of TheEmacsWiki.
+</longdescription>
+</pkgmetadata>