summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-07-23 12:46:02 +0200
committerUlrich Müller <ulm@gentoo.org>2021-07-23 12:49:23 +0200
commita8a731d48e4d5ec291c3c508d2bc5348722332b6 (patch)
tree52e9d99c47a5679a809f3023938298fc7dd905b6 /app-emacs/flim/flim-1.14.9_p20210529.ebuild
parentapp-emacs/apel: New snapshot 10.8_p20201106 (diff)
downloadgentoo-a8a731d48e4d5ec291c3c508d2bc5348722332b6.tar.gz
gentoo-a8a731d48e4d5ec291c3c508d2bc5348722332b6.tar.bz2
gentoo-a8a731d48e4d5ec291c3c508d2bc5348722332b6.zip
app-emacs/flim: New snapshot 1.14.9_p20210529
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/flim/flim-1.14.9_p20210529.ebuild')
-rw-r--r--app-emacs/flim/flim-1.14.9_p20210529.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/flim/flim-1.14.9_p20210529.ebuild b/app-emacs/flim/flim-1.14.9_p20210529.ebuild
new file mode 100644
index 000000000000..7dabe9f475b3
--- /dev/null
+++ b/app-emacs/flim/flim-1.14.9_p20210529.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="A library to provide basic features about message representation or encoding"
+HOMEPAGE="https://github.com/wanderlust/flim"
+GITHUB_SHA1="02735dede6603987e8309a76d0bc7a9ff9a5a227"
+SRC_URI="https://github.com/wanderlust/${PN}/archive/${GITHUB_SHA1}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+
+RDEPEND=">=app-emacs/apel-10.8"
+DEPEND="${RDEPEND}"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc FLIM-API.en NEWS VERSION README* ChangeLog*
+}