summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-10 08:17:20 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-10 08:58:18 +0100
commit9052371fa2dfd4c3ab13380534db94727f6926bc (patch)
tree8751f72fb8fc1b45aa55df94ddc645769646f9d5 /app-emacs/magit/magit-2.10.0.ebuild
parentapp-emacs/with-editor: add 2.5.9 (diff)
downloadgentoo-9052371fa2dfd4c3ab13380534db94727f6926bc.tar.gz
gentoo-9052371fa2dfd4c3ab13380534db94727f6926bc.tar.bz2
gentoo-9052371fa2dfd4c3ab13380534db94727f6926bc.zip
app-emacs/magit: add 2.10.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emacs/magit/magit-2.10.0.ebuild')
-rw-r--r--app-emacs/magit/magit-2.10.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/magit/magit-2.10.0.ebuild b/app-emacs/magit/magit-2.10.0.ebuild
new file mode 100644
index 000000000000..cb6e8ea26d8c
--- /dev/null
+++ b/app-emacs/magit/magit-2.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/"
+SRC_URI="https://github.com/magit/magit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${P}/lisp"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="../Documentation/*.texi"
+DOCS="../README.md ../Documentation/AUTHORS.md ../Documentation/RelNotes/${PV}.txt"
+
+DEPEND=">=app-emacs/dash-2.13.0 >=app-emacs/with-editor-2.5.9"
+RDEPEND="${DEPEND} >=dev-vcs/git-1.9.4"
+
+src_prepare() {
+ default
+ echo "(setq magit-version \"${PV}\")" > magit-version.el || die
+}