summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-07-16 08:07:19 +0200
committerUlrich Müller <ulm@gentoo.org>2023-07-16 08:09:03 +0200
commit80ff253cb2ae33ff9860be7d7cec65965764e5bb (patch)
treefcce64d7fc250d34c09fe885ad41decb272da5e5 /app-emacs/magit
parentnet-analyzer/zabbix: dropped obsolete (diff)
downloadgentoo-80ff253cb2ae33ff9860be7d7cec65965764e5bb.tar.gz
gentoo-80ff253cb2ae33ff9860be7d7cec65965764e5bb.tar.bz2
gentoo-80ff253cb2ae33ff9860be7d7cec65965764e5bb.zip
app-emacs/magit: Backport magit-inhibit-libgit patch
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/magit')
-rw-r--r--app-emacs/magit/files/magit-3.3.0-inhibit-libgit.patch22
-rw-r--r--app-emacs/magit/magit-3.3.0-r3.ebuild57
2 files changed, 79 insertions, 0 deletions
diff --git a/app-emacs/magit/files/magit-3.3.0-inhibit-libgit.patch b/app-emacs/magit/files/magit-3.3.0-inhibit-libgit.patch
new file mode 100644
index 000000000000..20fb2381b6c5
--- /dev/null
+++ b/app-emacs/magit/files/magit-3.3.0-inhibit-libgit.patch
@@ -0,0 +1,22 @@
+commit 451cbe5c24f2af7ed505f1422af6ad4e8f05205b
+Author: Jonas Bernoulli <jonas@bernoul.li>
+Date: Sun Feb 19 13:37:28 2023 +0100
+
+ Inhibit use of libgit by default
+
+--- lisp/magit-git.el
++++ lisp/magit-git.el
+@@ -66,8 +66,11 @@
+
+ ;;; Git implementations
+
+-(defvar magit-inhibit-libgit nil
+- "Whether to inhibit the use of libgit.")
++(defvar magit-inhibit-libgit t
++ "Whether to inhibit the use of libgit.
++Use of libgit is inhibited by default because support for libgit
++in magit is only a stub for now. There is no benefit in using
++it.")
+
+ (defvar magit--libgit-available-p 'unknown
+ "Whether libgit is available.
diff --git a/app-emacs/magit/magit-3.3.0-r3.ebuild b/app-emacs/magit/magit-3.3.0-r3.ebuild
new file mode 100644
index 000000000000..ac91b3d9a7f5
--- /dev/null
+++ b/app-emacs/magit/magit-3.3.0-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/magit/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/magit.git"
+else
+ SRC_URI="https://github.com/magit/magit/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="libgit"
+
+PATCHES=( "${FILESDIR}"/${P}-inhibit-libgit.patch )
+DOCS=( ../README.md ../Documentation/AUTHORS.md ../Documentation/RelNotes )
+ELISP_TEXINFO="../Documentation/*.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/dash-2.19.1
+ >=app-emacs/transient-0.3.6
+ >=app-emacs/with-editor-3.0.5
+ libgit? ( app-emacs/libegit2 )
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND+="
+ >=dev-vcs/git-2.0.0
+"
+
+src_prepare() {
+ default
+ use libgit || rm magit-libgit.el || die
+ echo "(setq magit-version \"${PV}\")" > magit-version.el || die
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ einfo "magit version 3.3.0 dropped necessity of the app-emacs/libegit2 package"
+ einfo "magit after 3.3.0 can now use the git executable directly,"
+ einfo "if you need the libegit backend, then please add app-emacs/libegit2 to @world"
+}