summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-05-31 06:53:44 +0200
committerHans de Graaff <graaff@gentoo.org>2019-05-31 07:05:25 +0200
commit8f00d2f2dd910a81a3e870dc9f092ae65d7ade21 (patch)
tree3ab514da141886bb6414e7e0683c1e5dfc6a03c0 /app-emacs/puppet-mode/puppet-mode-0.3.20180813.ebuild
parentapp-text/calibre: version bump to 3.44.0 (diff)
downloadgentoo-8f00d2f2dd910a81a3e870dc9f092ae65d7ade21.tar.gz
gentoo-8f00d2f2dd910a81a3e870dc9f092ae65d7ade21.tar.bz2
gentoo-8f00d2f2dd910a81a3e870dc9f092ae65d7ade21.zip
app-emacs/puppet-mode: add new snapshot with puppet bolt support
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-emacs/puppet-mode/puppet-mode-0.3.20180813.ebuild')
-rw-r--r--app-emacs/puppet-mode/puppet-mode-0.3.20180813.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/puppet-mode/puppet-mode-0.3.20180813.ebuild b/app-emacs/puppet-mode/puppet-mode-0.3.20180813.ebuild
new file mode 100644
index 000000000000..3c55e2f588ed
--- /dev/null
+++ b/app-emacs/puppet-mode/puppet-mode-0.3.20180813.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+COMMIT=7dee1b5a5debac6e56f9107492a413b6c0edb94d
+
+DESCRIPTION="Emacs major mode for editing Puppet manifests"
+HOMEPAGE="https://github.com/voxpupuli/puppet-mode"
+SRC_URI="https://github.com/voxpupuli/puppet-mode/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+
+DOCS="CHANGES.md README.md"
+SITEFILE="50${PN}-1-gentoo.el"
+
+# Tests require unpackaged ert-runner
+RESTRICT="test"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed -i -e 's/@VERSION@/'${PV}'/' puppet-mode.el || die
+}