summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/rnc-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/rnc-mode')
-rw-r--r--app-emacs/rnc-mode/Manifest1
-rw-r--r--app-emacs/rnc-mode/files/50rnc-mode-gentoo.el7
-rw-r--r--app-emacs/rnc-mode/metadata.xml5
-rw-r--r--app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild21
4 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/rnc-mode/Manifest b/app-emacs/rnc-mode/Manifest
new file mode 100644
index 000000000000..b90cddc62811
--- /dev/null
+++ b/app-emacs/rnc-mode/Manifest
@@ -0,0 +1 @@
+DIST RncMode-1_0b3.tgz 3420 SHA256 135cc63a65e079598d64fd2603500653b65e7ce1359acc9ceae4b65b8c7a3619 SHA512 0118e7b03dc039568ed427f9268878075077c360e34cd7fd9a565a11418161037890b08cc6169ddf92289ca1bdb66a1e373910b67735085a18618089729416cd WHIRLPOOL 02411df6699cc3301b37d7536cc5130eefc6775a5aeddb0770a4adc33f1b8cbeae48e06fccce56e8bb53362e7f57a57741b7db01a292df38275e603bb62616f3
diff --git a/app-emacs/rnc-mode/files/50rnc-mode-gentoo.el b/app-emacs/rnc-mode/files/50rnc-mode-gentoo.el
new file mode 100644
index 000000000000..a820f181e3ff
--- /dev/null
+++ b/app-emacs/rnc-mode/files/50rnc-mode-gentoo.el
@@ -0,0 +1,7 @@
+
+;;; rnc-mode site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'rnc-mode "rnc-mode")
+(add-to-list 'auto-mode-alist '("\\.rnc\\'" . rnc-mode))
diff --git a/app-emacs/rnc-mode/metadata.xml b/app-emacs/rnc-mode/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/rnc-mode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild b/app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild
new file mode 100644
index 000000000000..bc7e31ea1ce9
--- /dev/null
+++ b/app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit elisp
+
+MY_PV=${PV/./_}
+MY_PV=${MY_PV/_beta/b}
+
+DESCRIPTION="An Emacs mode for editing Relax NG compact schema files"
+HOMEPAGE="http://www.pantor.com/"
+SRC_URI="http://www.pantor.com/RncMode-${MY_PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+
+S="${WORKDIR}"