summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/thinks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/thinks')
-rw-r--r--app-emacs/thinks/Manifest1
-rw-r--r--app-emacs/thinks/files/50thinks-gentoo.el31
-rw-r--r--app-emacs/thinks/metadata.xml5
-rw-r--r--app-emacs/thinks/thinks-1.9.ebuild18
4 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/thinks/Manifest b/app-emacs/thinks/Manifest
new file mode 100644
index 000000000000..c79ca2f88015
--- /dev/null
+++ b/app-emacs/thinks/Manifest
@@ -0,0 +1 @@
+DIST thinks-1.9.el.bz2 2989 SHA256 fe51755231be601686a10901af276de9d746ef71b57b0954a21f0e9a98b35d38 SHA512 ba85485df0decb2825a832b60b01a4ae8ef2e32dc356d16b770a4b59a795e138f3c26e14d8eb27e97038d10d2633945c7b2bd14933fdf7815f6c0abc07de5802 WHIRLPOOL 32981107e64cd04aafe8d52ef2bf4a2b3ab2b5589514591437b0422a82ae7fd7e2ab92955a4ecccf58769858fbe0e37765c63db1304acd2fd54fe03a67df0f49
diff --git a/app-emacs/thinks/files/50thinks-gentoo.el b/app-emacs/thinks/files/50thinks-gentoo.el
new file mode 100644
index 000000000000..e9b9968517ac
--- /dev/null
+++ b/app-emacs/thinks/files/50thinks-gentoo.el
@@ -0,0 +1,31 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload (quote thinks) "thinks" "\
+Insert TEXT wrapped in a think bubble.
+
+Prefix a call to this function with \\[universal-argument] if you don't want
+the text to be filled for you.
+
+\(fn TEXT)" t nil)
+
+(autoload (quote thinks-region) "thinks" "\
+Bubble wrap region bounding START and END.
+
+Prefix a call to this function with \\[universal-argument] if you don't want
+the text to be filled for you.
+
+\(fn START END)" t nil)
+
+(autoload (quote thinks-yank) "thinks" "\
+Do a `yank' and bubble wrap the yanked text.
+
+Prefix a call to this function with \\[universal-argument] if you don't want
+the text to be filled for you.
+
+\(fn)" t nil)
+
+(autoload (quote thinks-maybe-region) "thinks" "\
+If region is active, bubble wrap region bounding START and END.
+If not, query for text to insert in bubble.
+
+\(fn)" t nil)
diff --git a/app-emacs/thinks/metadata.xml b/app-emacs/thinks/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/thinks/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/thinks/thinks-1.9.ebuild b/app-emacs/thinks/thinks-1.9.ebuild
new file mode 100644
index 000000000000..dbb5061f49df
--- /dev/null
+++ b/app-emacs/thinks/thinks-1.9.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Insert text in a think bubble"
+HOMEPAGE="http://www.davep.org/emacs/"
+# taken from http://www.davep.org/emacs/${PN}.el
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"