summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-12-23 10:46:55 +0100
committerUlrich Müller <ulm@gentoo.org>2019-12-23 10:47:23 +0100
commit369d90ff1a6ed3c8461229a81563afd276f71de7 (patch)
tree882286e61be8c22799b172697df33691acbfb68e /app-emacs/treepy
parentapp-emacs/treepy: Specify license more precisely. (diff)
downloadgentoo-369d90ff1a6ed3c8461229a81563afd276f71de7.tar.gz
gentoo-369d90ff1a6ed3c8461229a81563afd276f71de7.tar.bz2
gentoo-369d90ff1a6ed3c8461229a81563afd276f71de7.zip
app-emacs/treepy: Fix byte-compilation with Emacs 27.
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/treepy')
-rw-r--r--app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch12
-rw-r--r--app-emacs/treepy/treepy-0.1.1-r1.ebuild20
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch b/app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch
new file mode 100644
index 000000000000..0c7bfbad1b85
--- /dev/null
+++ b/app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch
@@ -0,0 +1,12 @@
+Fix byte-compilation with Emacs 27.
+
+--- treepy.el-0.1.1-orig/treepy.el
++++ treepy.el-0.1.1/treepy.el
+@@ -40,6 +40,7 @@
+ ;;
+ ;;; Code:
+
++(require 'cl-lib)
+ (require 'map)
+
+ ;;; Walk (recursive tree traversal)
diff --git a/app-emacs/treepy/treepy-0.1.1-r1.ebuild b/app-emacs/treepy/treepy-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..ed95978e0603
--- /dev/null
+++ b/app-emacs/treepy/treepy-0.1.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Generic tree traversing tools for Emacs Lisp"
+HOMEPAGE="https://github.com/volrath/treepy.el"
+SRC_URI="https://github.com/volrath/treepy.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.el-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=("${FILESDIR}"/${P}-cl-lib.patch)
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"