summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/twittering-mode/twittering-mode-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/twittering-mode/twittering-mode-9999.ebuild')
-rw-r--r--app-emacs/twittering-mode/twittering-mode-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/twittering-mode/twittering-mode-9999.ebuild b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
new file mode 100644
index 000000000000..c79b9ea0e1ed
--- /dev/null
+++ b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp elisp-common eutils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/hayamiz/twittering-mode.git"
+ inherit git-2
+ SRC_URI=""
+ KEYWORDS=""
+ IUSE="doc"
+else
+ SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RESTRICT="test"
+ IUSE=""
+fi
+
+DESCRIPTION="Emacs major mode for Twitter"
+HOMEPAGE="http://twmode.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="app-crypt/gnupg"
+
+src_compile() {
+ elisp-compile twittering-mode.el || die
+ [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ elisp-install ${PN} twittering-mode.el *.elc || die
+}