summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/volume
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/volume')
-rw-r--r--app-emacs/volume/Manifest1
-rw-r--r--app-emacs/volume/files/50volume-gentoo.el2
-rw-r--r--app-emacs/volume/files/volume-1.0-mode-line.patch14
-rw-r--r--app-emacs/volume/metadata.xml8
-rw-r--r--app-emacs/volume/volume-1.0-r1.ebuild23
5 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/volume/Manifest b/app-emacs/volume/Manifest
new file mode 100644
index 000000000000..05bba8b81cad
--- /dev/null
+++ b/app-emacs/volume/Manifest
@@ -0,0 +1 @@
+DIST volume-1.0.el.bz2 8044 SHA256 e5756c21695d4142259e56aebf5001ff3b469a6ef6453c3fb4af21768a58e588 SHA512 32672ef525571bc022d6c0f5f5f5f9d16bb5f57176e63a3dbaa67f41cef5a8bfef06468093c439601b2b3439f6e77e8e7e6d6c9245b18a77ebb409c64eece510 WHIRLPOOL 55a126c65d78cddd8cdc6ede360240a19d9e92b1c862840dcc9df59339fadd0b844457e5eb0aa7d0b34b506fc5c299038542df3d1e8629272ebd8e2d4cc9bd4a
diff --git a/app-emacs/volume/files/50volume-gentoo.el b/app-emacs/volume/files/50volume-gentoo.el
new file mode 100644
index 000000000000..2ab5a2bb5e04
--- /dev/null
+++ b/app-emacs/volume/files/50volume-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'volume "volume" "Tweak your sound card volume." t)
diff --git a/app-emacs/volume/files/volume-1.0-mode-line.patch b/app-emacs/volume/files/volume-1.0-mode-line.patch
new file mode 100644
index 000000000000..2b3e4ccd33ef
--- /dev/null
+++ b/app-emacs/volume/files/volume-1.0-mode-line.patch
@@ -0,0 +1,14 @@
+Use `mode-line' instead of `modeline' for Emacs 24 compat.
+Patch taken from upstream repo.
+
+--- a/volume.el
++++ b/volume.el
+@@ -973,7 +973,7 @@
+ (select-window
+ (split-window-vertically
+ (if (and (fboundp 'face-attr-construct)
+- (plist-get (face-attr-construct 'modeline) :box))
++ (plist-get (face-attr-construct 'mode-line) :box))
+ -3 -2)))
+ (switch-to-buffer volume-buffer)))
+ ((not (eq (current-buffer) volume-buffer))
diff --git a/app-emacs/volume/metadata.xml b/app-emacs/volume/metadata.xml
new file mode 100644
index 000000000000..4b82c0179582
--- /dev/null
+++ b/app-emacs/volume/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="github">dbrock/volume-el</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/volume/volume-1.0-r1.ebuild b/app-emacs/volume/volume-1.0-r1.ebuild
new file mode 100644
index 000000000000..6edf136cf372
--- /dev/null
+++ b/app-emacs/volume/volume-1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Tweak your sound card volume from Emacs"
+HOMEPAGE="https://github.com/dbrock/volume-el"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+# NOTE we might define the following which volume.el can work with by
+# default, but volume.el can really work with anything.
+
+# RDEPEND="|| ( media-sound/aumixer media-sound/alsa-utils )"
+
+ELISP_PATCHES="${P}-mode-line.patch"
+SITEFILE="50${PN}-gentoo.el"