summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/wgrep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/wgrep')
-rw-r--r--app-emacs/wgrep/Manifest1
-rw-r--r--app-emacs/wgrep/files/50wgrep-gentoo.el1
-rw-r--r--app-emacs/wgrep/metadata.xml12
-rw-r--r--app-emacs/wgrep/wgrep-2.1.10.ebuild20
4 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/wgrep/Manifest b/app-emacs/wgrep/Manifest
new file mode 100644
index 000000000000..ffa70b86401e
--- /dev/null
+++ b/app-emacs/wgrep/Manifest
@@ -0,0 +1 @@
+DIST wgrep-2.1.10.el.xz 8708 SHA256 fa45f5724abd200c432701423f373f8106cec88c939b590bace394ba1b0a7ada SHA512 39761964406d3eedca9253f2f29f81dd9ee71c4e049a985c236ada4dd9b70dc553bf1e9e94cb6d3c8749f065146e2759a46a6ac52ed8e5e5f046e196798bc681 WHIRLPOOL 11b806d10dc1f089c959808ee47a1cc07beba534bc7df8bd3cb9cc17aa4ad7b8ec7ac381de410d84ebf436cb31001e83bca3bbc911e0b8c981ed19dab46650d5
diff --git a/app-emacs/wgrep/files/50wgrep-gentoo.el b/app-emacs/wgrep/files/50wgrep-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/wgrep/files/50wgrep-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/wgrep/metadata.xml b/app-emacs/wgrep/metadata.xml
new file mode 100644
index 000000000000..4be47a3f1ad3
--- /dev/null
+++ b/app-emacs/wgrep/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ wgrep allows you to edit a grep buffer and apply those changes to
+ the file buffer.
+</longdescription>
+<upstream>
+ <remote-id type="github">mhayashi1120/Emacs-wgrep</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/wgrep/wgrep-2.1.10.ebuild b/app-emacs/wgrep/wgrep-2.1.10.ebuild
new file mode 100644
index 000000000000..6694d1ca0f17
--- /dev/null
+++ b/app-emacs/wgrep/wgrep-2.1.10.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Writable grep buffer and apply the changes to files"
+HOMEPAGE="https://github.com/mhayashi1120/Emacs-wgrep"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="See commentary in ${SITELISP}/${PN}/wgrep.el for documentation.
+ \n\nTo activate wgrep, add the following line to your ~/.emacs file:
+ \n\t(require 'wgrep)"