summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/yatex/yatex-1.77.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/yatex/yatex-1.77.ebuild')
-rw-r--r--app-emacs/yatex/yatex-1.77.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/yatex/yatex-1.77.ebuild b/app-emacs/yatex/yatex-1.77.ebuild
new file mode 100644
index 000000000000..06874094ce23
--- /dev/null
+++ b/app-emacs/yatex/yatex-1.77.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="Yet Another TeX mode for Emacs"
+HOMEPAGE="http://www.yatex.org/"
+SRC_URI="http://www.yatex.org/${P/-/}.tar.gz"
+
+KEYWORDS="amd64 ppc ~ppc64 x86"
+SLOT="0"
+LICENSE="YaTeX"
+IUSE="linguas_ja"
+
+S="${WORKDIR}/${P/-/}"
+ELISP_PATCHES="${PN}-1.76-gentoo.patch
+ ${PN}-1.76-direntry.patch
+ ${PN}-1.77-texinfo-5.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ # byte-compilation fails (as of 1.74): yatexlib.el requires fonts
+ # that are only available under X
+
+ cd docs
+ makeinfo yatexe.tex yahtmle.tex || die
+
+ if use linguas_ja; then
+ iconv -f WINDOWS-31J -t UTF-8 yatexj.tex >yatex-ja.texi || die
+ iconv -f WINDOWS-31J -t UTF-8 yahtmlj.tex >yahtml-ja.texi || die
+ makeinfo yatex-ja.texi yahtml-ja.texi || die
+ fi
+}
+
+src_install() {
+ elisp-install ${PN} *.el || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ insinto ${SITEETC}/${PN}
+ doins help/YATEXHLP.eng
+ doinfo docs/yatex.info* docs/yahtml.info*
+ dodoc docs/*.eng
+
+ if use linguas_ja; then
+ doins help/YATEXHLP.jp
+ doinfo docs/yatex-ja.info* docs/yahtml-ja.info*
+ dodoc 00readme install docs/{htmlqa,qanda} docs/*.doc
+ fi
+}