summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-11-10 07:19:04 +0100
committerHans de Graaff <graaff@gentoo.org>2018-11-10 07:19:04 +0100
commit0d82fe6ce4cf2efda6790894a04607b391fed690 (patch)
tree2d530473c7ad2cf368323cb414b7a8c328d5b75c /app-emacs
parentdev-ruby/tins: add 1.19.0 (diff)
downloadgentoo-0d82fe6ce4cf2efda6790894a04607b391fed690.tar.gz
gentoo-0d82fe6ce4cf2efda6790894a04607b391fed690.tar.bz2
gentoo-0d82fe6ce4cf2efda6790894a04607b391fed690.zip
app-emacs/graphql: fix compilation without ghub
Don't install examples.el which depends on ghub, leading to circular dependencies. Fixes: https://bugs.gentoo.org/670779 Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/graphql/graphql-0.1.1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/app-emacs/graphql/graphql-0.1.1.ebuild b/app-emacs/graphql/graphql-0.1.1.ebuild
index eb8fe947e5f0..9dccfdd1f85d 100644
--- a/app-emacs/graphql/graphql-0.1.1.ebuild
+++ b/app-emacs/graphql/graphql-0.1.1.ebuild
@@ -20,3 +20,10 @@ DOCS="README.md"
# Tries to download emake tool on the fly
RESTRICT="test"
+
+src_prepare() {
+ # Avoid examples which would require circular dependencies
+ rm -f examples.el || die
+
+ default
+}