summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-13 13:20:56 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-13 13:38:01 +0100
commit140dc7c1b553ae15784bc51cf0e176ae71ac5fc5 (patch)
tree15ff26fac078eb211d0bd40a164eac751f21ad5b /app-emacs
parentapp-emacs/docker: drop old 2.2.0_p20221012 (diff)
downloadgentoo-140dc7c1b553ae15784bc51cf0e176ae71ac5fc5.tar.gz
gentoo-140dc7c1b553ae15784bc51cf0e176ae71ac5fc5.tar.bz2
gentoo-140dc7c1b553ae15784bc51cf0e176ae71ac5fc5.zip
app-emacs/docker: bump to 2.3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/docker/Manifest1
-rw-r--r--app-emacs/docker/docker-2.3.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/docker/Manifest b/app-emacs/docker/Manifest
index 29ccbfe845c9..8d245bc9331e 100644
--- a/app-emacs/docker/Manifest
+++ b/app-emacs/docker/Manifest
@@ -1 +1,2 @@
DIST docker.el-2.2.0_p20230605.tar.gz 112737 BLAKE2B f5cfa26e0b32cf490aeb28cdbb5df232e1b981fb0e42f21569ed120606dc10a2ba7d00783fb49f4f5f83d7567f5512388a5f19bdd2a06ba4979bef86ac9e12a7 SHA512 76a52199c00bf8a67dfef3bbbad9b3a5fc0d892cf5379fd069d07f42c34fc376c9cee1578acb3b7d1371948385c8bf1159c8f39843a413db19ed7af334af1fbe
+DIST docker.el-2.3.1.tar.gz 113225 BLAKE2B bb941c18cc137d8678d3d7bd248df09ff6cfae48a9381b64ce49799c8a1b9f56acde08584600f4403605e778e4c764d7063ae41aa4a3f487f2cf6a86ce56f0fa SHA512 42345d44de582329f328d516445210a00653f4f49a8c0bc9960c8c2269fe5bcd25aab99d4ddd0c0dc390ab3891f459706a68bd956b731ef1d3f984d80f0b5184
diff --git a/app-emacs/docker/docker-2.3.1.ebuild b/app-emacs/docker/docker-2.3.1.ebuild
new file mode 100644
index 000000000000..0b643fa7c93e
--- /dev/null
+++ b/app-emacs/docker/docker-2.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Emacs integration for Docker"
+HOMEPAGE="https://github.com/Silex/docker.el/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Silex/${PN}.el.git"
+else
+ SRC_URI="https://github.com/Silex/${PN}.el/archive/${PV}.tar.gz
+ -> ${PN}.el-${PV}.tar.gz"
+ S="${WORKDIR}/${PN}.el-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/transient-0.4.3
+ app-emacs/dash
+ app-emacs/emacs-aio
+ app-emacs/s
+ app-emacs/tablist
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.md screenshots )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}