summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-06 19:45:18 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-06 20:00:15 +0200
commit2fb7ea275e890ed9437a526174c27aa2483049ec (patch)
tree328582a549128010750fa496a8f29eb1e1bf44e8 /app-emacs
parentapp-emacs/bbdb: bump to 3.2.2d_p20231122 (diff)
downloadgentoo-2fb7ea275e890ed9437a526174c27aa2483049ec.tar.gz
gentoo-2fb7ea275e890ed9437a526174c27aa2483049ec.tar.bz2
gentoo-2fb7ea275e890ed9437a526174c27aa2483049ec.zip
app-emacs/yatex: bump to 1.83
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/yatex/Manifest1
-rw-r--r--app-emacs/yatex/yatex-1.83.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/yatex/Manifest b/app-emacs/yatex/Manifest
index 3b3184d1355e..8549582bb47f 100644
--- a/app-emacs/yatex/Manifest
+++ b/app-emacs/yatex/Manifest
@@ -1 +1,2 @@
DIST yatex1.82.tar.gz 387358 BLAKE2B 77c88563e3beb7b29ac8a4d7204d14b966c9a88b1c2f04c6160089f0b61a70c9d6aa135d2e1cee6e13a90cc108428ce80e7ef0d0b8852b9a8651e67f34af7e1e SHA512 8c2890fc12e93aace5ac51e24da315a9d241aec023a3c67187c1fd28d2a7a02d1688b7e1177e1ba13411ecb394b5d581298c735cd80195e663bbdcf240f10fe5
+DIST yatex1.83.tar.gz 389259 BLAKE2B 40a5475c1b46e93531eeac3b7ed3e90f7a68c0faad91cc9c74b38af0e36a83578032615a2dfdcd7a6ede2b9eda36e128581c162a84b913362612cd07df9f1d81 SHA512 7e12532a5af8139b99457ff1137b19e5d1272f6bc13e3baea62d57e6ec036154ae733696ae8b6c1c1b8a6949aaa0425a34a8485ce61cbe0df72ceee1489eaedf
diff --git a/app-emacs/yatex/yatex-1.83.ebuild b/app-emacs/yatex/yatex-1.83.ebuild
new file mode 100644
index 000000000000..989294002687
--- /dev/null
+++ b/app-emacs/yatex/yatex-1.83.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Yet Another TeX mode for Emacs"
+HOMEPAGE="http://www.yatex.org/"
+SRC_URI="http://www.${PN}.org/${P/-}.tar.gz"
+S="${WORKDIR}/${P/-}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="l10n_ja"
+
+BDEPEND="
+ l10n_ja? ( virtual/libiconv )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.76-direntry.patch"
+ "${FILESDIR}/${PN}-1.80-texinfo-5.patch"
+ "${FILESDIR}/${PN}-1.82-texinfo.patch"
+)
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "/(help-dir/,/)))/c\ (help-dir \"${SITEETC}/${PN}\"))" "${PN}hlp.el"
+
+ elisp_src_prepare
+}
+
+src_compile() {
+ cd docs
+ makeinfo {${PN},yahtml}e.tex || die
+
+ if use l10n_ja; then
+ iconv -f WINDOWS-31J -t UTF-8 "${PN}j.tex" > "${PN}-ja.texi" || die
+ iconv -f WINDOWS-31J -t UTF-8 yahtmlj.tex > yahtml-ja.texi || die
+ makeinfo {${PN},yahtml}-ja.texi || die
+ fi
+}
+
+src_install() {
+ elisp-install "${PN}" ./*.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins help/YATEXHLP.eng
+ doinfo docs/{${PN},yahtml}.info*
+ dodoc install docs/*.eng
+
+ if use l10n_ja; then
+ doins help/YATEXHLP.jp
+ doinfo docs/{${PN},yahtml}-ja.info*
+ dodoc 00readme "${PN}.new" docs/{htmlqa,qanda,*.doc}
+ fi
+}