summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Oehme <markus@jonglieren-jena.de>2019-06-24 12:00:29 +0200
committerUlrich Müller <ulm@gentoo.org>2019-06-24 12:37:20 +0200
commit766f5f01ed572a38929fccd9aacd5f53cf1bc0a2 (patch)
treec476717a69ee14870be639a28d876a3affaa4654 /app-emacs
parentnet-mail/dovecot: Use acct-group/mail (diff)
downloadgentoo-766f5f01ed572a38929fccd9aacd5f53cf1bc0a2.tar.gz
gentoo-766f5f01ed572a38929fccd9aacd5f53cf1bc0a2.tar.bz2
gentoo-766f5f01ed572a38929fccd9aacd5f53cf1bc0a2.zip
app-emacs/apel: Version bump.
Bug: https://bugs.gentoo.org/688560 Signed-off-by: Markus Oehme <markus@jonglieren-jena.de> [ulm@gentoo.org: EAPI 7 bump, minor cleanup] Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/apel/Manifest1
-rw-r--r--app-emacs/apel/apel-10.8_p20190407.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/apel/Manifest b/app-emacs/apel/Manifest
index 4ae2aa39ddc9..bab93f88e479 100644
--- a/app-emacs/apel/Manifest
+++ b/app-emacs/apel/Manifest
@@ -1,2 +1,3 @@
DIST apel-10.8-030_Use-new-style-backquotes.patch.gz 7869 BLAKE2B 93b93a089693a2fec68033b44f1cf96117fcdcb9dad5dbbf4283a79cd19f358c2a3bdc80ce2f7517e8b396182141583a371c21a8df7db7d05156ffd16987a872 SHA512 4074dc612feb2d63637bea2e9303423d4e9e035fad7f440d2da5331a6adc08f5ec61abb5087c2c4c72ec8931d1ccc4db3ffd061bcf3150d20c222c8df2e0b274
DIST apel-10.8.tar.gz 126326 BLAKE2B 6fc8f04006a971e9d48dbf5f7b43e201a4f5fa515210bb69829bc3b0f05aba2e9f205915e6117e20220ae5b48a6543520533dc95a90754a30ff3fb8094779901 SHA512 39f13f15ec0a078d8f8dfe797899474cf4dfeb0bf7b8432a0c05bb38cf134d805c171a66b3d3efd074fbf294d68006d1e1d49903e45f1991d79cdcb4cca4aa9d
+DIST apel-10.8_p20190407.tar.gz 94808 BLAKE2B 47540e8c3ce96cc91efefe521942a3df4ee8423c7796d7e66b14bed7e9d662469a0767dd4863ae130fb114a1f9335d95abd13d61b6811e039db75e28679ac0f6 SHA512 6c780b0643f248e2a1409f1cea794dc6be515ee2ae766ead0834996bd9c13852492af1b9c343c4efda06fd057fae0c1b8a1ffc6b55b1469afbc7cbf1b579ea68
diff --git a/app-emacs/apel/apel-10.8_p20190407.ebuild b/app-emacs/apel/apel-10.8_p20190407.ebuild
new file mode 100644
index 000000000000..6dd02e5f803a
--- /dev/null
+++ b/app-emacs/apel/apel-10.8_p20190407.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs"
+HOMEPAGE="https://github.com/wanderlust/apel"
+GITHUB_SHA1="d146ddbf8818e81d3577d5eee7825d377bec0c73"
+SRC_URI="${HOMEPAGE}/archive/${GITHUB_SHA1}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+src_prepare() {
+ elisp_src_prepare
+ cat <<-EOF >>APEL-CFG || die
+ (setq APEL_PREFIX "apel")
+ (setq EMU_PREFIX "apel")
+ EOF
+}
+
+src_compile() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}"
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" \
+ install
+ elisp-site-file-install "${FILESDIR}/50apel-gentoo.el"
+ dodoc ChangeLog README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "See the README.en file in /usr/share/doc/${PF} for tips"
+ elog "on how to customize this package."
+}