summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2024-04-29 11:51:48 +0200
committerArsen Arsenović <arsen@gentoo.org>2024-04-30 01:17:55 +0200
commit8f2427922536e26d4ad3fa82294305e1f7f522a6 (patch)
tree88d369cb33b2e71bd3f02102840a927167173678 /app-emacs
parentapp-emacs/eldoc-box: new package, add 1.11.1 (diff)
downloadgentoo-8f2427922536e26d4ad3fa82294305e1f7f522a6.tar.gz
gentoo-8f2427922536e26d4ad3fa82294305e1f7f522a6.tar.bz2
gentoo-8f2427922536e26d4ad3fa82294305e1f7f522a6.zip
app-emacs/eldoc-box: add 9999
Closes: https://github.com/gentoo/gentoo/pull/36476 Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/eldoc-box/eldoc-box-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/eldoc-box/eldoc-box-9999.ebuild b/app-emacs/eldoc-box/eldoc-box-9999.ebuild
new file mode 100644
index 000000000000..e466b68c6ef4
--- /dev/null
+++ b/app-emacs/eldoc-box/eldoc-box-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Child frame doc for Eglot and anything that uses ElDoc"
+HOMEPAGE="https://github.com/casouri/eldoc-box"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/casouri/${PN}.git"
+else
+ SRC_URI="https://github.com/casouri/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-make-autoload-file
+ elisp_src_compile
+}