summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-06-19 22:04:02 +0200
committerUlrich Müller <ulm@gentoo.org>2016-06-19 22:04:02 +0200
commit96f01189ac17120541e810d82ec7479f814365a4 (patch)
tree3d57846c7d02b557ffec89bca3de7ade2f315147 /app-emacs
parentx11-libs/xforms: Regenerate Manifest file. (diff)
downloadgentoo-96f01189ac17120541e810d82ec7479f814365a4.tar.gz
gentoo-96f01189ac17120541e810d82ec7479f814365a4.tar.bz2
gentoo-96f01189ac17120541e810d82ec7479f814365a4.zip
app-emacs/ebuild-mode: Version bump.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ebuild-mode/Manifest1
-rw-r--r--app-emacs/ebuild-mode/ebuild-mode-1.31.ebuild21
-rw-r--r--app-emacs/ebuild-mode/files/50ebuild-mode-gentoo-1.31.el13
3 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/ebuild-mode/Manifest b/app-emacs/ebuild-mode/Manifest
index 983f4fb3da6e..f68f314f851b 100644
--- a/app-emacs/ebuild-mode/Manifest
+++ b/app-emacs/ebuild-mode/Manifest
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.29.tar.xz 29296 SHA256 d4f095b1e58f7182218caa2d5839c0dec3eeb4f10386d846a36a895bcb979190 SHA512 bf81a5af269db49c2e9907daf7fc5d457ac07a5b9d921aa8084a55fc9065d71d114ea4210fba393b791e2473d5ab8bf37c2af2724f889061537e37e383574344 WHIRLPOOL 7e6167c79c5a22c9eab1ba91244f8ac18343092b459e8f8aa38308cd4003ec510e8be88d79e44c6432737816679b1c48491d1f3095c4f891eae499ee025c5018
DIST ebuild-mode-1.30.tar.xz 29308 SHA256 7f270854579cbe78fbcc919d26404dbe9933859ba10b5d975801d63d03a6e76e SHA512 0d45f2bd5c8857745c76bffa7e39a223494cc2362f4c5369ffe93aa5608d6ff98d9d246583a4b2346e9900858a9161f8483e75139d4861d0412afa2dbf4408b2 WHIRLPOOL 95cc9b7a5c1a5257fd9c10fc5144344d12c0edee94b2353f73a93253bb5c21e74b622f5f74804cb315a879b12fbebab957a99cf1140ae9551bc944e9d8470c57
+DIST ebuild-mode-1.31.tar.xz 29492 SHA256 09bcea9ede052bf33bde402f472340570fb8eff67196cd69d4ea4820d84edf0e SHA512 8e4868a40966d5b56573425fe41d638ef1bc10a1161759218c22d33cbeb67ed3e1c75553c58a1f1c9e3ff0d2d8b25794404909a2bd19e76be93a037f8f3a0581 WHIRLPOOL d256a716baa2a276e62790e8996815e608c22e6bb2072f62a4089cc8b594d9e5470f7d574c33c23cc6817c74d59d1927e7591f8d8150985641ba61c50d6335c2
diff --git a/app-emacs/ebuild-mode/ebuild-mode-1.31.ebuild b/app-emacs/ebuild-mode/ebuild-mode-1.31.ebuild
new file mode 100644
index 000000000000..d00920062ec8
--- /dev/null
+++ b/app-emacs/ebuild-mode/ebuild-mode-1.31.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit readme.gentoo-r1 elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DOCS="ChangeLog keyword-generation.sh"
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo-1.31.el"
+DOC_CONTENTS="Some optional features may require installation of additional
+ packages, like app-portage/gentoolkit-dev for echangelog."
diff --git a/app-emacs/ebuild-mode/files/50ebuild-mode-gentoo-1.31.el b/app-emacs/ebuild-mode/files/50ebuild-mode-gentoo-1.31.el
new file mode 100644
index 000000000000..5a096923c4c5
--- /dev/null
+++ b/app-emacs/ebuild-mode/files/50ebuild-mode-gentoo-1.31.el
@@ -0,0 +1,13 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ebuild-mode "ebuild-mode"
+ "Major mode for Portage .ebuild and .eclass files." t)
+(autoload 'gentoo-newsitem-mode "gentoo-newsitem-mode"
+ "Major mode for Gentoo GLEP 42 news items." t)
+
+(add-to-list 'auto-mode-alist '("\\.\\(ebuild\\|eclass\\)\\'" . ebuild-mode))
+(add-to-list 'auto-mode-alist
+ '("/[0-9]\\{4\\}-[01][0-9]-[0-3][0-9]-.+\\.[a-z]\\{2\\}\\.txt\\'"
+ . gentoo-newsitem-mode))
+(add-to-list 'interpreter-mode-alist '("openrc-run" . sh-mode))
+(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode))
+(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\)\\'" 'utf-8)