summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-23 00:34:11 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-23 00:34:11 +0200
commita0f4817e8b5fc75b8b872a4589a4a27bac61741e (patch)
tree685067f7a99d02e4dcc15d04bb70d0a5ec232423 /app-emacs
parentapp-emacs/consult: drop old 1.3 (diff)
downloadgentoo-a0f4817e8b5fc75b8b872a4589a4a27bac61741e.tar.gz
gentoo-a0f4817e8b5fc75b8b872a4589a4a27bac61741e.tar.bz2
gentoo-a0f4817e8b5fc75b8b872a4589a4a27bac61741e.zip
app-emacs/consult: bump to 1.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/consult/Manifest1
-rw-r--r--app-emacs/consult/consult-1.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/consult/Manifest b/app-emacs/consult/Manifest
index 7e0689d18763..1e3566d6db4f 100644
--- a/app-emacs/consult/Manifest
+++ b/app-emacs/consult/Manifest
@@ -1 +1,2 @@
DIST consult-1.4.tar.gz 103709 BLAKE2B 5326856b6bafc0a52d525971d84bd2fd3e0450aa1e8060d9ad49dabc6620fb2b721e5a26ba8d219bd889723109af766ba7fb8faa510301031f9372c798a8853d SHA512 4721820d288a357ea3432a850556a85cb037c1ddc262cada62d75e80641f1b402dd6edfceabb89b8dc386ae391081e02d2550f8773f9760ae267f3af8e381cb6
+DIST consult-1.5.tar.gz 103884 BLAKE2B 3244582f7b5db6e17ef8b42d1482088c263fce02124596728c3afa17673a1e17565b82b2ba37a6843af72279cf36df49febda389c42d5a6c6be8a7a0ca3ad05f SHA512 2e2b96a7bb6b0a311796a76a1f5609f4c7ad48eb1d3c98c6431aeec1803222c437a552483f198de7d195e5a4cded79e00b673382a9cfbefe18864fa2d170f2bf
diff --git a/app-emacs/consult/consult-1.5.ebuild b/app-emacs/consult/consult-1.5.ebuild
new file mode 100644
index 000000000000..7f3ed9bf0123
--- /dev/null
+++ b/app-emacs/consult/consult-1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read for GNU Emacs"
+HOMEPAGE="https://github.com/minad/consult/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-28.1
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}