summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-20 02:01:52 +0000
committerSam James <sam@gentoo.org>2021-10-20 02:04:28 +0000
commit139c9ff844ca4bb077fa1f69b574fea83fd72b33 (patch)
tree19678b2d338c02aaeefe7ec8795a9dc9eb488f0c /app-emulation/bochs
parentapp-emulation/bochs: add version 2.7 ebuild (diff)
downloadgentoo-139c9ff844ca4bb077fa1f69b574fea83fd72b33.tar.gz
gentoo-139c9ff844ca4bb077fa1f69b574fea83fd72b33.tar.bz2
gentoo-139c9ff844ca4bb077fa1f69b574fea83fd72b33.zip
app-emulation/bochs: adapt to upstream changes
svga support is gone and disasm is no longer a configure option. Bug: https://bugs.gentoo.org/774195 See: https://github.com/gentoo/gentoo/pull/21944 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/bochs-2.7.ebuild24
-rw-r--r--app-emulation/bochs/bochs-9999.ebuild27
2 files changed, 23 insertions, 28 deletions
diff --git a/app-emulation/bochs/bochs-2.7.ebuild b/app-emulation/bochs/bochs-2.7.ebuild
index 0f90dbea1511..0191aeeca226 100644
--- a/app-emulation/bochs/bochs-2.7.ebuild
+++ b/app-emulation/bochs/bochs-2.7.ebuild
@@ -11,7 +11,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="3dnow avx debugger doc gdb ncurses readline svga sdl +smp vnc X +x86-64"
+IUSE="3dnow avx debugger doc gdb ncurses readline sdl +smp vnc X +x86-64"
REQUIRED_USE="
avx? ( x86-64 )
gdb? ( !debugger !smp )
@@ -19,26 +19,27 @@ REQUIRED_USE="
"
RDEPEND="
- X? ( x11-libs/libICE
+ ncurses? ( sys-libs/ncurses:= )
+ readline? ( sys-libs/readline:= )
+ sdl? ( media-libs/libsdl )
+ X? (
+ x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
- x11-libs/libXpm )
- sdl? ( media-libs/libsdl )
- svga? ( media-libs/svgalib )
- readline? ( sys-libs/readline:= )
- ncurses? ( sys-libs/ncurses:= )
+ x11-libs/libXpm
+ )
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"
BDEPEND="
- doc? ( app-text/docbook-sgml-utils )
- sys-apps/sed
>=app-text/opensp-1.5
+ doc? ( app-text/docbook-sgml-utils )
"
src_prepare() {
default
+
sed -i "s:^docdir.*:docdir = ${EPREFIX}/usr/share/doc/${PF}:" \
Makefile.in || die
}
@@ -50,7 +51,6 @@ src_configure() {
--enable-cdrom \
--enable-clgd54xx \
--enable-cpu-level=6 \
- --enable-disasm \
--enable-e1000 \
--enable-gameport \
--enable-iodebug \
@@ -77,9 +77,7 @@ src_configure() {
$(use_enable x86-64) \
$(use_with ncurses term) \
$(use_with sdl) \
- $(use_with svga) \
$(use_with vnc rfb) \
$(use_with X x) \
- $(use_with X x11) \
- ${myconf}
+ $(use_with X x11)
}
diff --git a/app-emulation/bochs/bochs-9999.ebuild b/app-emulation/bochs/bochs-9999.ebuild
index fa7208ddc58f..2ddaf54249b1 100644
--- a/app-emulation/bochs/bochs-9999.ebuild
+++ b/app-emulation/bochs/bochs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,9 +12,8 @@ ESVN_REPO_URI="svn://svn.code.sf.net/p/bochs/code/trunk/bochs"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
-IUSE="3dnow avx debugger doc gdb ncurses readline svga sdl +smp vnc X +x86-64"
+IUSE="3dnow avx debugger doc gdb ncurses readline sdl +smp vnc X +x86-64"
REQUIRED_USE="
avx? ( x86-64 )
gdb? ( !debugger !smp )
@@ -22,26 +21,27 @@ REQUIRED_USE="
"
RDEPEND="
- X? ( x11-libs/libICE
+ ncurses? ( sys-libs/ncurses:= )
+ readline? ( sys-libs/readline:= )
+ sdl? ( media-libs/libsdl )
+ X? (
+ x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
- x11-libs/libXpm )
- sdl? ( media-libs/libsdl )
- svga? ( media-libs/svgalib )
- readline? ( sys-libs/readline:= )
- ncurses? ( sys-libs/ncurses:= )
+ x11-libs/libXpm
+ )
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"
BDEPEND="
- doc? ( app-text/docbook-sgml-utils )
- sys-apps/sed
>=app-text/opensp-1.5
+ doc? ( app-text/docbook-sgml-utils )
"
src_prepare() {
default
+
sed -i "s:^docdir.*:docdir = ${EPREFIX}/usr/share/doc/${PF}:" \
Makefile.in || die
}
@@ -53,7 +53,6 @@ src_configure() {
--enable-cdrom \
--enable-clgd54xx \
--enable-cpu-level=6 \
- --enable-disasm \
--enable-e1000 \
--enable-gameport \
--enable-iodebug \
@@ -80,9 +79,7 @@ src_configure() {
$(use_enable x86-64) \
$(use_with ncurses term) \
$(use_with sdl) \
- $(use_with svga) \
$(use_with vnc rfb) \
$(use_with X x) \
- $(use_with X x11) \
- ${myconf}
+ $(use_with X x11)
}