summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-04-19 13:20:39 -0700
committerZac Medico <zmedico@gentoo.org>2020-04-19 13:21:49 -0700
commit43975b0f40f20ce9664b597a2265116786f32eba (patch)
treeace4ebda51dcbb4f1dc2cedc53d88154a9a2e085 /app-emulation/conmon/conmon-2.0.15.ebuild
parentpackage.mask: Last rite x11-terms/roxterm (diff)
downloadgentoo-43975b0f40f20ce9664b597a2265116786f32eba.tar.gz
gentoo-43975b0f40f20ce9664b597a2265116786f32eba.tar.bz2
gentoo-43975b0f40f20ce9664b597a2265116786f32eba.zip
app-emulation/conmon: Bump to version 2.0.15
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/conmon/conmon-2.0.15.ebuild')
-rw-r--r--app-emulation/conmon/conmon-2.0.15.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/conmon/conmon-2.0.15.ebuild b/app-emulation/conmon/conmon-2.0.15.ebuild
new file mode 100644
index 000000000000..b76b5b1f201f
--- /dev/null
+++ b/app-emulation/conmon/conmon-2.0.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="1bddbf7051a973f4a4fecf06faa0c48e82f1e9e1"
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+SRC_URI="https://github.com/containers/conmon/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="systemd"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:=
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| $(PKG_CONFIG) --exists libsystemd-journal | false |' \
+ -e 's| $(PKG_CONFIG) --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+}
+
+src_compile() {
+ emake GIT_COMMIT="${EGIT_COMMIT}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ install
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/conmon || die
+ dodoc README.md
+}