summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-06-19 19:40:44 -0700
committerZac Medico <zmedico@gentoo.org>2020-06-19 19:40:44 -0700
commit93d0a60dd9a0dd581753c20ce6fa83eaae53930d (patch)
tree30142efe491866042c24315ee727a4e2bcab3f63 /app-emulation/conmon/conmon-2.0.18.ebuild
parentdev-perl/Clipboard: Bump to version 0.260.0 (diff)
downloadgentoo-93d0a60dd9a0dd581753c20ce6fa83eaae53930d.tar.gz
gentoo-93d0a60dd9a0dd581753c20ce6fa83eaae53930d.tar.bz2
gentoo-93d0a60dd9a0dd581753c20ce6fa83eaae53930d.zip
app-emulation/conmon: Bump to version 2.0.18
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/conmon/conmon-2.0.18.ebuild')
-rw-r--r--app-emulation/conmon/conmon-2.0.18.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/conmon/conmon-2.0.18.ebuild b/app-emulation/conmon/conmon-2.0.18.ebuild
new file mode 100644
index 000000000000..ae692f5f2207
--- /dev/null
+++ b/app-emulation/conmon/conmon-2.0.18.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="7b3e303be8f1aea7e0d4a784c8e64a75c14756a4"
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+SRC_URI="https://github.com/containers/conmon/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="systemd"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:=
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| $(PKG_CONFIG) --exists libsystemd-journal | false |' \
+ -e 's| $(PKG_CONFIG) --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+}
+
+src_compile() {
+ emake GIT_COMMIT="${EGIT_COMMIT}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ install
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/conmon || die
+ dodoc README.md
+}