summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-03-06 14:04:13 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-03-06 14:21:46 +0100
commitcf152bbddbb1f4f6bfd38459160c12cdc13a0e57 (patch)
treed2998f00bd9126d92938440cf262c31f45b7cc1e /app-emulation/containerd/containerd-0.2.3_p20170131.ebuild
parentdev-ml/ocaml-dns: Bump to 0.19.1 (diff)
downloadgentoo-cf152bbddbb1f4f6bfd38459160c12cdc13a0e57.tar.gz
gentoo-cf152bbddbb1f4f6bfd38459160c12cdc13a0e57.tar.bz2
gentoo-cf152bbddbb1f4f6bfd38459160c12cdc13a0e57.zip
app-emulation/containerd: Add snapshot for docker-1.13.x
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-emulation/containerd/containerd-0.2.3_p20170131.ebuild')
-rw-r--r--app-emulation/containerd/containerd-0.2.3_p20170131.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/containerd/containerd-0.2.3_p20170131.ebuild b/app-emulation/containerd/containerd-0.2.3_p20170131.ebuild
new file mode 100644
index 000000000000..ed0d3ebb9215
--- /dev/null
+++ b/app-emulation/containerd/containerd-0.2.3_p20170131.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="aa8187dbd3b7ad67d8e5e3a15115d3eef43a7ed1"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened +seccomp"
+
+DEPEND=""
+RDEPEND=">=app-emulation/docker-runc-1.0.0_rc2
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd* bin/ctr
+}