summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-09 20:01:23 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-09 20:01:37 +0100
commita5cbf1fcd7bdbbf6f5e4168ff807d0627400f0a0 (patch)
treec012becb55ca5a32be9567c2de8d2aae8c71d6ba /app-emulation/containerd
parentapp-emulation/containerd: use hardened USEflag for -fno-PIC (diff)
downloadgentoo-a5cbf1fcd7bdbbf6f5e4168ff807d0627400f0a0.tar.gz
gentoo-a5cbf1fcd7bdbbf6f5e4168ff807d0627400f0a0.tar.bz2
gentoo-a5cbf1fcd7bdbbf6f5e4168ff807d0627400f0a0.zip
app-emulation/containerd: Sync live ebuild
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/containerd-9999.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/app-emulation/containerd/containerd-9999.ebuild b/app-emulation/containerd/containerd-9999.ebuild
index 4b81e8a432ac..ab4ce7e80243 100644
--- a/app-emulation/containerd/containerd-9999.ebuild
+++ b/app-emulation/containerd/containerd-9999.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="https://containerd.tools"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="+seccomp"
+IUSE="hardened +seccomp"
DEPEND=""
RDEPEND=">=app-emulation/runc-1.0.0_rc2
@@ -31,12 +31,9 @@ RDEPEND=">=app-emulation/runc-1.0.0_rc2
S=${WORKDIR}/${P}/src/${EGO_PN}
src_compile() {
- local options=( $(usex seccomp "seccomp") ) myldflags
+ local options=( $(usex seccomp "seccomp") )
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- if gcc-specs-pie; then
- myldflags="-extldflags -fno-PIC"
- fi
- LDFLAGS=${myldflags} emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
}
src_install() {