summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-12-05 11:51:13 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-12-05 11:54:34 -0600
commitbdabf26b16f05bdd6c672019d72f9286a4c80334 (patch)
tree7f929cd4ad0a57fef910bf165d9898fe2ba5a817 /app-emulation/diskimage-builder
parentnet-libs/ldns: stable 1.8.0-r1 for hppa, bug #827968 (diff)
downloadgentoo-bdabf26b16f05bdd6c672019d72f9286a4c80334.tar.gz
gentoo-bdabf26b16f05bdd6c672019d72f9286a4c80334.tar.bz2
gentoo-bdabf26b16f05bdd6c672019d72f9286a4c80334.zip
app-emulation/diskimage-builder: 3.16.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.16.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index d1410a706c9e..ae0ab8a0fd54 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -2,3 +2,4 @@ DIST diskimage-builder-3.13.0.tar.gz 494027 BLAKE2B 27a88118d688018a5f842e0d483e
DIST diskimage-builder-3.15.0.tar.gz 498998 BLAKE2B 75d0b538eee233d41639fd543e8f91bbe5f39007593e083d9b17b4e8fb77740082acdbaed738b4b1d7fcf360f7ebf0aa38aea341dfd316e9d0dac1dd97cc8f8b SHA512 5dacc6946b0fecc6a49b04b66c46a8ff6021674c1934b16d6698672ece23b698cc1a406c31a41b356969790f8cc7811db67de0246bc654d3341b38ee7f1af617
DIST diskimage-builder-3.15.1.tar.gz 499267 BLAKE2B 9a106a9a36bed61e29c3e694aaa0482d6b91b11dc10278efc9befdd5b019f59971393883a577bc7988d5c160fd891a3833be949b6a428919989c855e864cb39e SHA512 93a9f8c0d1b02532211d27d4e7ddcf53988f83d8688cc615e26ea2f6d48ff25c95d6d34213bf43d5c630ef5a7c2150886894053220428d19cebb5aaa5818de59
DIST diskimage-builder-3.15.2.tar.gz 499511 BLAKE2B 246317025aba0dc12337615383be6724c3b9cfae35e1a30ba78ef0754ae2277293d68780fdd66ae1ab0a6721a8be7670cf10cd42a3f4b9c84eda7fad448da421 SHA512 e9be229ffe4d8161f7fd8fef0f998eab9a17d300304f3da7afaa65d85c93fde4d2a6b23e43f1a617770d34c88b4667bf68e61872cf298adc17bd37f9f96c274e
+DIST diskimage-builder-3.16.0.tar.gz 499320 BLAKE2B 2cf520957c270696a6c4c7f59d6c875d30e7245c9fa24d556ef90eca4bab9e45eb95ecc422bc84ac202df0ba8afbaac412663892c8ab18bd4847e5d630ea4e43 SHA512 e592fd9200681314519b6e58b4b3ba9106d3834e83e708b3f32c125a8f597252f43abec05b37a9f6b30397874d53b56740e2374d6d13f69e737d460f191bdd98
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.16.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.16.0.ebuild
new file mode 100644
index 000000000000..92726b9c7654
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.16.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"