summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-20 17:18:56 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-20 17:18:56 -0600
commitf4733ff1679fe8e2e4c6e36aea0e43739188f7d8 (patch)
tree8466d72261479c2b4aae00715328be2b01607947 /app-emulation/diskimage-builder
parentwww-plugins/chrome-binary-plugins: automated update (65.0.3325.73, 66.0.3346.8) (diff)
downloadgentoo-f4733ff1679fe8e2e4c6e36aea0e43739188f7d8.tar.gz
gentoo-f4733ff1679fe8e2e4c6e36aea0e43739188f7d8.tar.bz2
gentoo-f4733ff1679fe8e2e4c6e36aea0e43739188f7d8.zip
app-emulation/diskimage-builder: 2.11.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.11.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 7fa901bbb5da..86920bc231e3 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-2.10.1.tar.gz 338370 BLAKE2B d2417af55924971ac6c8ee803c7c9bf788ecd9a16affe90077eff51a58924c81e82728eef344749b5687cc26ff9e355a7611f4e2a0a5501217344eb9bca2bb00 SHA512 4c9ff1b7182b3c207d769bdcd142f23a6d9e2a8f040694ab75d41284bb96ad07305ae78e486343f22d13d8c8cbef5c66eaaf4638f0fd8f7158cf3520da587e88
+DIST diskimage-builder-2.11.0.tar.gz 334400 BLAKE2B 0bb15b83b8fe1d5217197e491c83010b098f00ff13a8abf5da2890cdcb1b2a7cc81c8a5befea9b1c184ce10a35a73068ecc336594f813831584ca0b94b822ddb SHA512 3caa7809552c472e28906587889f1e310855ef4686d1da1adcb1dadb4cf3550ded30f7ec7483d4889f96a9e1d11b19dcb53b0458c75a801a378ac01e8b0d26e5
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.11.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.11.0.ebuild
new file mode 100644
index 000000000000..b7ce708c6881
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.11.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"